summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2023-06-09 11:37:16 +1000
committerRod Kay2023-06-09 11:37:16 +1000
commit319016560cebc063254b51e96323a06d3807a59d (patch)
tree5c22abcb5f2503c765979c15aaabbcbceb8948b6
parentbff2119e09a8bcf50fd0f885b486b3ae3b9b4451 (diff)
downloadaur-319016560cebc063254b51e96323a06d3807a59d.tar.gz
Update to version '24.0w'.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD70
2 files changed, 41 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38a7a3d442b6..b884edabcd75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = langkit
pkgdesc = Compiler for syntactic and semantic language analysis libraries.
- pkgver = 23.0.0
- pkgrel = 4
+ pkgver = 24.0w
+ pkgrel = 1
epoch = 1
- url = https://github.com/AdaCore/langkit/
+ url = https://github.com/AdaCore/langkit
arch = i686
arch = x86_64
license = Apache
@@ -24,9 +24,9 @@ pkgbase = langkit
depends = gnatcoll-iconv
depends = gnatcoll-gmp
depends = python
- source = langkit-23.0.0.tar.gz::https://github.com/AdaCore/langkit//archive/v23.0.0.tar.gz
+ source = file:///opt/gnatstudio-sources/langkit-24.0w-20230324-16391-src.tar.gz
source = 0001-Replace-calls-to-inspect.getargspec-with-getfullargs.patch
- sha256sums = 50cb8b08fc180eab939a5747c52f68c073c7b77e6c12ef5c5aa488845d5c934c
+ sha256sums = aea03ed51466fdca9bee32274a09a08cce645094da1cabea87a75829eb56491c
sha256sums = dddf397b5a2de8b0bb45fb4d8cf49d6440911e92594cda8c1af1e045c348c547
pkgname = langkit
diff --git a/PKGBUILD b/PKGBUILD
index 573c3611dbe3..302ca67c09ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,49 @@
# Maintainer: Rod Kay <rodakay5 at gmail dot com>
-pkgname=langkit
epoch=1
-pkgver=23.0.0
-pkgrel=4
+pkgname=langkit
+pkgver=24.0w
+pkgrel=1
pkgdesc='Compiler for syntactic and semantic language analysis libraries.'
-url='https://github.com/AdaCore/langkit/'
-arch=('i686' 'x86_64')
-license=('Apache')
-
-depends=('gnatcoll-iconv' 'gnatcoll-gmp' 'python')
-makedepends=('gprbuild' 'texlive-bin'
- 'python-sphinx' 'python-e3-core' 'python-funcy' 'python-mako'
- 'python-e3-testsuite' 'python-pygments' 'python-coverage'
- 'python-docutils' 'python-pexpect' 'python-ptyprocess' 'python-pycodestyle'
- 'python-railroad-diagrams')
-
-# 'python-gnatdbg' 'python-autopep8' 'python-flake8' 'python-mypy' 'python-sphinx-rtd-theme'
-# 'python-types-docutils' 'python-types-gdb' 'python-yapf'
-
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
- "0001-Replace-calls-to-inspect.getargspec-with-getfullargs.patch")
+url=https://github.com/AdaCore/langkit
+arch=(i686 x86_64)
+license=(Apache)
+
+depends=(gnatcoll-iconv gnatcoll-gmp python)
+makedepends=(gprbuild
+ texlive-bin
+ python-sphinx
+ python-e3-core
+ python-funcy
+ python-mako
+ python-e3-testsuite
+ python-pygments
+ python-coverage
+ python-docutils
+ python-pexpect
+ python-ptyprocess
+ python-pycodestyle
+ python-railroad-diagrams)
+
+source=(file:///opt/gnatstudio-sources/$pkgname-$pkgver-20230324-16391-src.tar.gz
+ 0001-Replace-calls-to-inspect.getargspec-with-getfullargs.patch)
-sha256sums=("50cb8b08fc180eab939a5747c52f68c073c7b77e6c12ef5c5aa488845d5c934c"
- "dddf397b5a2de8b0bb45fb4d8cf49d6440911e92594cda8c1af1e045c348c547")
-
-prepare()
-{
- cd "$srcdir/$pkgname-$pkgver"
-
- patch -p1 -i ../0001-Replace-calls-to-inspect.getargspec-with-getfullargs.patch
-}
+sha256sums=(aea03ed51466fdca9bee32274a09a08cce645094da1cabea87a75829eb56491c
+ dddf397b5a2de8b0bb45fb4d8cf49d6440911e92594cda8c1af1e045c348c547)
build()
{
- cd "$srcdir/$pkgname-$pkgver"
+ cd $srcdir/$pkgname-$pkgver-20230428-16136-src
ADA_FLAGS="$CFLAGS"
ADA_FLAGS="${ADA_FLAGS//-Wformat}"
ADA_FLAGS="${ADA_FLAGS//-Werror=format-security}"
# Build the Langkit_Support library, used by all Langkit-generated libraries.
+ #
python manage.py build-langkit-support \
--library-types=static,static-pic,relocatable \
--build-mode=prod \
@@ -56,21 +56,23 @@ build()
package()
{
- cd "$srcdir/$pkgname-$pkgver"
+ cd $srcdir/$pkgname-$pkgver-20230428-16136-src
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
python manage.py install-langkit-support \
--library-types=static,static-pic,relocatable \
--build-mode=prod \
- "$pkgdir/usr"
+ $pkgdir/usr
# Install the license.
+ #
install -D -m644 \
- "LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ LICENSE.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
# Install the documentation.
+ #
pushd doc/_build/html
for file in $(find . -type f); do
@@ -78,4 +80,4 @@ package()
done
popd
-}
+} \ No newline at end of file