summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-07-16 21:53:29 +0200
committerXiretza2021-07-16 21:53:29 +0200
commit36eff3832000bcfa26e82a46b0812c6d9bcb205f (patch)
treedf634c2e9253bfdf6d6f19ab90b9e0f0b8426bc5
parente361388c9c7d55dd22ea497ab40beaf2849f6aae (diff)
downloadaur-36eff3832000bcfa26e82a46b0812c6d9bcb205f.tar.gz
Build python in build(), fix quoting issues
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb3ac99b11ea..cf90b596aee0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,6 +32,7 @@ build()
--build-mode=prod \
--gargs="-R -cargs $ADA_FLAGS -largs $LDFLAGS -gargs"
+ python setup.py build
make -C doc html
}
@@ -39,7 +40,7 @@ package()
{
cd "$srcdir/$_extract_dir"
- python setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
python manage.py install-langkit-support \
--library-types=static,static-pic,relocatable \
@@ -57,9 +58,10 @@ package()
"$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
# Install the documentation.
- cd doc/_build/html
-
+ pushd doc/_build/html
for file in $(find . -type f); do
- install -m 644 -D ${file} "$pkgdir/usr/share/doc/$pkgname"/${file#source/}
+ install -m 644 -D "$file" "$pkgdir/usr/share/doc/$pkgname/$file"
done
+ popd
}
+# vim: set et ts=4: