summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRod Kay2022-02-07 08:57:18 +1100
committerRod Kay2022-02-07 08:57:18 +1100
commitdf41ae26bb2f87232bd83c6935ff2954036c6de9 (patch)
tree2802acde630d9bfc6d2bab6b68c9e1c0d02bfef0
parent64b122ef313ed82f664d8e2846e786d8dce6b8ca (diff)
downloadaur-df41ae26bb2f87232bd83c6935ff2954036c6de9.tar.gz
Update to version '22.0.0'.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 876ce684edc7..4067ff4c193d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = langkit
pkgdesc = Compiler for syntactic and semantic language analysis libraries.
- pkgver = 20210518
- pkgrel = 2
+ pkgver = 20211103
+ pkgrel = 1
url = https://github.com/AdaCore/langkit/
arch = i686
arch = x86_64
@@ -15,7 +15,7 @@ pkgbase = langkit
makedepends = python-mako
depends = gnatcoll-iconv
depends = python
- source = langkit-20210518.tar.gz::https://community.download.adacore.com/v1/709e5ffa66fd8181655951e0ec8ed04e1d2977e2?filename=langkit-2021-20210518-19B8E-src.tar.gz&rand=280
- sha1sums = 709e5ffa66fd8181655951e0ec8ed04e1d2977e2
+ source = https://github.com/AdaCore/langkit/archive/refs/tags/v22.0.0.tar.gz
+ sha1sums = 24ed555520e8789b6a0a828605e8d42eac9caf38
pkgname = langkit
diff --git a/PKGBUILD b/PKGBUILD
index 82f4352a9204..66edba95c35e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Rod Kay <rodakay5 at gmail dot com>
pkgname=langkit
-pkgver=20210518
-pkgrel=2
+pkgver=20211103
+pkgrel=1
pkgdesc='Compiler for syntactic and semantic language analysis libraries.'
url='https://github.com/AdaCore/langkit/'
@@ -12,24 +12,21 @@ license=('GPL3' 'custom')
depends=('gnatcoll-iconv' 'python')
makedepends=('gprbuild' 'texlive-bin' 'python-sphinx' 'python-e3-core' 'python-funcy' 'python-mako')
-_extract_dir="$pkgname-2021-$pkgver-19B8E-src"
-_hash=709e5ffa66fd8181655951e0ec8ed04e1d2977e2
-
-source=("$pkgname-$pkgver.tar.gz::https://community.download.adacore.com/v1/$_hash?filename=$_extract_dir.tar.gz&rand=280")
-sha1sums=("$_hash")
+source=("https://github.com/AdaCore/langkit/archive/refs/tags/v22.0.0.tar.gz")
+sha1sums=("24ed555520e8789b6a0a828605e8d42eac9caf38")
build()
{
- cd "$srcdir/$_extract_dir"
+ cd "$srcdir/langkit-22.0.0"
ADA_FLAGS="$CFLAGS"
ADA_FLAGS="${ADA_FLAGS//-Wformat}"
ADA_FLAGS="${ADA_FLAGS//-Werror=format-security}"
# Build the Langkit_Support library, used by all Langkit-generated libraries.
- python manage.py build-langkit-support \
+ python manage.py build-langkit-support \
--library-types=static,static-pic,relocatable \
- --build-mode=prod \
+ --build-mode=prod \
--gargs="-R -cargs $ADA_FLAGS -largs $LDFLAGS -gargs"
python setup.py build
@@ -38,13 +35,13 @@ build()
package()
{
- cd "$srcdir/$_extract_dir"
+ cd "$srcdir/langkit-22.0.0"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- python manage.py install-langkit-support \
+ python manage.py install-langkit-support \
--library-types=static,static-pic,relocatable \
- --build-mode=prod \
+ --build-mode=prod \
"$pkgdir/usr"
# Install the license.