summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2021-07-16 21:52:29 +0200
committerXiretza2021-07-16 21:52:29 +0200
commite361388c9c7d55dd22ea497ab40beaf2849f6aae (patch)
tree6bcaeb109e2f644bbca5590141992722392b59cf
parent56b6b2ed8378a3b9287b09d7526239ab9a3def94 (diff)
downloadaur-e361388c9c7d55dd22ea497ab40beaf2849f6aae.tar.gz
Build static libraries
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 134e36c991da..fb3ac99b11ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ build()
# Build the Langkit_Support library, used by all Langkit-generated libraries.
python manage.py build-langkit-support \
- --library-types=relocatable \
+ --library-types=static,static-pic,relocatable \
--build-mode=prod \
--gargs="-R -cargs $ADA_FLAGS -largs $LDFLAGS -gargs"
@@ -42,7 +42,7 @@ package()
python setup.py install --root="$pkgdir"
python manage.py install-langkit-support \
- --library-types=relocatable \
+ --library-types=static,static-pic,relocatable \
--build-mode=prod \
"$pkgdir/usr"