summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2019-06-29 09:48:53 +0200
committerPierre-Marie de Rodat2019-06-29 09:48:53 +0200
commit30778631b1e96d41b93eb1ab982506d0e3e053ad (patch)
tree06169f3dc9c1b1d6798d950d88c333272bfa1213
parentbc8ba773c8ba4cc42020bab15fbb14c5969f8527 (diff)
downloadaur-30778631b1e96d41b93eb1ab982506d0e3e053ad.tar.gz
Update build procedure to use --library-types
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d695ec4ca80..013d77acdef5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = langkit-git
pkgdesc = Compiler for syntactic and semantic language analysis libraries
- pkgver = r4926.893bb29e
+ pkgver = r6135.442192c9
pkgrel = 1
url = https://github.com/AdaCore/langkit/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index d70e2525f3c3..d85d34957de3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=langkit-git
-pkgver=r4926.893bb29e
+pkgver=r6135.442192c9
pkgrel=1
pkgdesc='Compiler for syntactic and semantic language analysis libraries'
@@ -45,17 +45,14 @@ build()
# Build the Langkit_Support library, used by all Langkit-generated
# libraries.
- python2 scripts/build-langkit_support.py generate
- python2 scripts/build-langkit_support.py \
- --disable-static --enable-shared \
- build --build-mode=prod --gargs="-R"
-
+ #
# TODO: build & install static libraries. For now, this fails because
# auto-initialized static libraries are built using partial linking (ld's
# -r option), which conflicts with GCC's by default -pie option.
- true || python2 scripts/build-langkit_support.py -vdebug \
- --enable-static --disable-shared \
- build --build-mode=prod
+ python2 scripts/build-langkit_support.py generate
+ python2 scripts/build-langkit_support.py \
+ --library-types relocatable \
+ build --build-mode=prod --gargs="-R"
}
package()
@@ -64,6 +61,6 @@ package()
python2 setup.py install --root="$pkgdir"
python2 scripts/build-langkit_support.py \
- --disable-static --enable-shared \
+ --library-types relocatable \
install "$pkgdir/usr"
}