summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2020-06-13 18:15:19 +0200
committerPierre-Marie de Rodat2020-06-13 18:15:19 +0200
commit470b9ce5fe951cf4ebc92fe935c996569cd3ba9c (patch)
treeb41bfcd5a93883c320442987dbecf453c0183592
parentf422ca87190edd50752ea3aab6f526d7cd416cbe (diff)
downloadaur-470b9ce5fe951cf4ebc92fe935c996569cd3ba9c.tar.gz
Update after the switch to Python3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
-rw-r--r--python2.patch19
3 files changed, 15 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1771a87fd6c0..ac503fc13c84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = langkit-git
pkgdesc = Compiler for syntactic and semantic language analysis libraries
- pkgver = r6608.7e98ba83
+ pkgver = r6816.55fe04716
pkgrel = 1
url = https://github.com/AdaCore/langkit/
arch = any
@@ -14,18 +14,15 @@ pkgbase = langkit-git
depends = python-psutil
depends = python-sphinx
depends = python-yaml
- depends = python2-docutils
- depends = python2-e3-core
- depends = python2-enum34
- depends = python2-funcy
- depends = python2-mako
+ depends = python-docutils
+ depends = python-e3-core
+ depends = python-funcy
+ depends = python-mako
depends = yapf
provides = langkit
conflicts = langkit
source = git+https://github.com/AdaCore/langkit.git
- source = python2.patch
sha1sums = SKIP
- sha1sums = 755fde34ecd1eeb2deeacf67148e22d2934ff6b4
pkgname = langkit-git
diff --git a/PKGBUILD b/PKGBUILD
index f72671aca3b3..699248173622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=langkit-git
-pkgver=r6608.7e98ba83
+pkgver=r6816.55fe04716
pkgrel=1
pkgdesc='Compiler for syntactic and semantic language analysis libraries'
@@ -9,19 +9,16 @@ url='https://github.com/AdaCore/langkit/'
arch=('any')
license=('GPL')
-depends=('gcc-ada' 'gprbuild' 'gnatcoll-core' 'gnatcoll-iconv'
- 'autopep8' 'python-psutil' 'python-sphinx' 'python-yaml'
- 'python2-docutils' 'python2-e3-core' 'python2-enum34' 'python2-funcy'
- 'python2-mako' 'yapf')
+depends=('gcc-ada' 'gprbuild' 'gnatcoll-core' 'gnatcoll-iconv' 'autopep8'
+ 'python-psutil' 'python-sphinx' 'python-yaml' 'python-docutils'
+ 'python-e3-core' 'python-funcy' 'python-mako' 'yapf')
makedepends=('git')
provides=('langkit')
conflicts=('langkit')
-source=('git+https://github.com/AdaCore/langkit.git'
- 'python2.patch')
-sha1sums=('SKIP'
- '755fde34ecd1eeb2deeacf67148e22d2934ff6b4')
+source=('git+https://github.com/AdaCore/langkit.git')
+sha1sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -30,12 +27,6 @@ pkgver() {
"$(git rev-parse --short HEAD)"
}
-prepare()
-{
- cd "$srcdir/${pkgname%-git}"
- patch -p0 -i "$srcdir/python2.patch"
-}
-
build()
{
cd "$srcdir/${pkgname%-git}"
@@ -49,8 +40,8 @@ build()
# TODO: build & install static libraries. For now, this fails because
# auto-initialized static libraries are built using partial linking (ld's
# -r option), which conflicts with GCC's by default -pie option.
- python2 scripts/build-langkit_support.py generate
- python2 scripts/build-langkit_support.py \
+ python scripts/build-langkit_support.py generate
+ python scripts/build-langkit_support.py \
--library-types relocatable \
build --build-mode=prod --gargs="-R"
}
@@ -58,9 +49,9 @@ build()
package()
{
cd "$srcdir/${pkgname%-git}"
- python2 setup.py install --root="$pkgdir"
+ python setup.py install --root="$pkgdir"
- python2 scripts/build-langkit_support.py \
+ python scripts/build-langkit_support.py \
--library-types relocatable \
install --build-mode=prod "$pkgdir/usr"
}
diff --git a/python2.patch b/python2.patch
deleted file mode 100644
index 968b0fc909f0..000000000000
--- a/python2.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git scripts/create-project.py scripts/create-project.py
-index 16c4bb2c..7a7e10eb 100755
---- scripts/create-project.py
-+++ scripts/create-project.py
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#! /usr/bin/env python2
-
- from __future__ import absolute_import, division, print_function
-
-@@ -40,7 +40,7 @@ def generate(lang_name):
- os.chmod('manage.py', 0755)
-
-
--MANAGE_TEMPLATE = '''#! /usr/bin/env python
-+MANAGE_TEMPLATE = '''#! /usr/bin/env python2
-
- import os
-