summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPierre-Marie de Rodat2018-03-18 17:21:32 +0100
committerPierre-Marie de Rodat2018-03-18 17:21:32 +0100
commitaadcd24ec0e95d19305863204375a4e9fc935d5c (patch)
tree4f3888b629c462fa5d212ae4b9f29fd79206ff0c
parent40afded067edcdd4d88d9e735cd111f31df722c3 (diff)
downloadaur-aadcd24ec0e95d19305863204375a4e9fc935d5c.tar.gz
Build and install Langkit_Support (runtime support)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD25
2 files changed, 25 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3625818b9339..9d695ec4ca80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = langkit-git
pkgdesc = Compiler for syntactic and semantic language analysis libraries
- pkgver = r4919.15d0f2f2
+ pkgver = r4926.893bb29e
pkgrel = 1
url = https://github.com/AdaCore/langkit/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index e3a9875293ae..e04b36bb33e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pierre-Marie de Rodat <pmderodat on #ada at freenode.net>
pkgname=langkit-git
-pkgver=r4919.15d0f2f2
+pkgver=r4926.893bb29e
pkgrel=1
pkgdesc='Compiler for syntactic and semantic language analysis libraries'
@@ -36,8 +36,31 @@ prepare()
patch -p0 -i "$srcdir/python2.patch"
}
+build()
+{
+ cd "$srcdir/${pkgname%-git}"
+
+ # Build the Langkit_Support library, used by all Langkit-generated
+ # libraries.
+ python2 scripts/build-langkit_support.py generate
+ python2 scripts/build-langkit_support.py \
+ --disable-static --enable-shared \
+ build --build-mode=prod --gargs="-R"
+
+ # TODO: build & install static libraries. For now, this fails because
+ # auto-initialized static libraries are built using partial linking (ld's
+ # -r option), which conflicts with GCC's by default -pie option.
+ true || python2 scripts/build-langkit_support.py -vdebug \
+ --enable-static --disable-shared \
+ build --build-mode=prod
+}
+
package()
{
cd "$srcdir/${pkgname%-git}"
python2 setup.py install --root="$pkgdir"
+
+ python2 scripts/build-langkit_support.py \
+ --disable-static --enable-shared \
+ install "$pkgdir/usr"
}