summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-03-10 11:48:13 -0700
committerBenjamin Denhartog2020-03-10 11:48:13 -0700
commit92f5dd12158477a0424b1c7c2e6dfc6e081ae94d (patch)
tree2ae5f2ca56240516ecff18a8569a9199d14d427d
downloadaur-92f5dd12158477a0424b1c7c2e6dfc6e081ae94d.tar.gz
feat(languageclient-neovim-bin): add package at version 0.1.156
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD49
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e41b8101538
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = languageclient-neovim-bin
+ pkgdesc = Language Server Protocol (LSP) support for Vim and NeoVim.
+ pkgver = 0.1.156
+ pkgrel = 1
+ url = https://github.com/autozimu/LanguageClient-neovim
+ arch = x86_64
+ license = MIT
+ provides = languageclient-neovim
+ source = languageclient-neovim-bin-0.1.156.tar.gz::https://github.com/autozimu/LanguageClient-neovim/archive/0.1.156.tar.gz
+ source = https://github.com/autozimu/LanguageClient-neovim/releases/download/0.1.156/languageclient-0.1.156-x86_64-unknown-linux-musl
+ sha256sums = 18ead0ece35b848d93284b300f11e11bc2fb978c2dbacb2fe687bf4b8ddac22d
+ sha256sums = b817d2cd2552f1b96a0516252320c8907febf325266a66d4182bf1131500efa2
+
+pkgname = languageclient-neovim-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..386de7e64b01
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+languageclient-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b77dcfabdc1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Benjamin Denhartog <ben@sudoforge.com>
+
+_pkgname=LanguageClient-neovim
+pkgname=languageclient-neovim-bin
+pkgver=0.1.156
+pkgrel=1
+pkgdesc="Language Server Protocol (LSP) support for Vim and NeoVim."
+url="https://github.com/autozimu/LanguageClient-neovim"
+provides=('languageclient-neovim')
+license=('MIT')
+arch=('x86_64')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz"
+ "${url}/releases/download/${pkgver}/${pkgname%-neovim-bin}-${pkgver}-x86_64-unknown-linux-musl")
+sha256sums=('18ead0ece35b848d93284b300f11e11bc2fb978c2dbacb2fe687bf4b8ddac22d'
+ 'b817d2cd2552f1b96a0516252320c8907febf325266a66d4182bf1131500efa2')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Install the license file
+ install -D -m 644 \
+ "LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE.txt"
+
+ # Install the executable to local bin/ directory to take advantage of
+ # the iterative copying, below. `install` is used to ensure the correct
+ # mode is set.
+ install -D -m 755 \
+ "${srcdir}/${pkgname%-neovim-bin}-${pkgver}-x86_64-unknown-linux-musl" \
+ "bin/${pkgname%-neovim-bin}"
+
+ # Create runtime directories
+ install -d -m 755 "${pkgdir}/usr/share/vim/vimfiles"
+ install -d -m 755 "${pkgdir}/usr/share/nvim/runtime"
+
+ # Install vimfiles from the project into the appropriate runtime directories
+ for d in autoload bin doc plugin rplugin; do
+ case $d in
+ rplugin)
+ # vim doesn't have "remote plugins", so we only need to move this into
+ # neovim's runtime directory
+ cp -r "$d" "${pkgdir}/usr/share/nvim/runtime"
+ ;;
+ *)
+ cp -r "$d" "${pkgdir}/usr/share/vim/vimfiles"
+ cp -r "$d" "${pkgdir}/usr/share/nvim/runtime"
+ esac
+ done
+}