summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Pizarro Callejas2021-12-21 13:20:44 -0300
committerJorge Pizarro Callejas2021-12-21 13:20:44 -0300
commitf880dec26c39e2fdf93c92df5286f619cdbbe9de (patch)
treefec905c943304cb254c5a27265b7ceb71ec59192
parente7634dc25271ed15f1087080886e5657ef595f83 (diff)
downloadaur-f880dec26c39e2fdf93c92df5286f619cdbbe9de.tar.gz
Fixing lanshare-git versioning, makedepends and info
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 919a8658ca26..8e84c3e3dcc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lanshare-git
pkgdesc = LAN Share is a cross platform local area network file transfer application, built using Qt GUI framework.
- pkgver = continuous.r4.gaa7a3bc
+ pkgver = r4.gaa7a3bc
pkgrel = 1
url = https://github.com/abdularis/LAN-Share
arch = i686
@@ -9,7 +9,8 @@ pkgbase = lanshare-git
arch = armv6h
arch = armv7h
arch = aarch64
- license = GPL
+ license = GPL3
+ makedepends = git
depends = qt5-base
provides = lanshare
conflicts = lanshare
diff --git a/PKGBUILD b/PKGBUILD
index 9bc4579a3870..82cced6e1e49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
-# Maintainer: Jorge Pizarro-Callejas <jpizarrocallejas@gmail.com>
+# Maintainer: Jorge Pizarro-Callejas (jorgicio) <jpizarrocallejas@gmail.com>
+# Former Maintainer: sigmacool
+# Contributor: FabioLolix
pkgname=lanshare-git
_pkgname="LAN-Share"
-pkgver=continuous.r4.gaa7a3bc
+pkgver=1.2.1.r28.gaa7a3bc
pkgrel=1
pkgdesc="LAN Share is a cross platform local area network file transfer application, built using Qt GUI framework."
arch=(i686 x86_64 arm armv6h armv7h aarch64)
url="https://github.com/abdularis/LAN-Share"
-license=(GPL)
+license=(GPL3)
depends=(qt5-base)
+makedepends=(git)
source=("git+https://github.com/abdularis/$_pkgname.git")
sha256sums=('SKIP')
provides=(${pkgname%-git})
@@ -16,7 +19,7 @@ conflicts=(${pkgname%-git})
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --exclude continuous | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {