summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Mijieux2017-03-05 11:43:57 +0100
committerThomas Mijieux2017-03-05 11:45:33 +0100
commit61537bf7c4bb564f69d6c9101e544c2bde1fb769 (patch)
tree2a33bb8060f0f613917ee64867e6a357af5872a8
downloadaur-61537bf7c4bb564f69d6c9101e544c2bde1fb769.tar.gz
initial commit; PKGBUILD, LICENSE and .SRCINFO
-rw-r--r--.SRCINFO39
-rw-r--r--LICENSE.blas19
-rw-r--r--PKGBUILD85
3 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa1b8aa5158c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = lapack-tmg
+ pkgdesc = Linear Algebra PACKage with TMG lib
+ pkgver = 3.7.0
+ pkgrel = 1
+ url = http://www.netlib.org/lapack
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc-fortran
+ makedepends = cmake
+ makedepends = python
+ source = http://www.netlib.org/lapack/lapack-3.7.0.tgz
+ source = LICENSE.blas
+ sha1sums = 27dbd06bedc76619150f8e28de6412f7df0c649a
+ sha1sums = 2491a151a37f0162b25fc4e4e9a8ac444b574a76
+
+pkgname = lapack-tmg
+ depends = blas-tmg
+ provides = lapack
+ conflicts = lapack
+
+pkgname = blas-tmg
+ pkgdesc = Basic Linear Algebra Subprograms
+ depends = gcc-libs
+ provides = blas
+ conflicts = blas
+
+pkgname = cblas-tmg
+ pkgdesc = C interface to BLAS
+ depends = blas-tmg
+ provides = cblas
+ conflicts = cblas
+
+pkgname = lapacke-tmg
+ pkgdesc = C interface to LAPACK
+ depends = lapack-tmg
+ provides = lapacke
+ conflicts = lapacke
+
diff --git a/LICENSE.blas b/LICENSE.blas
new file mode 100644
index 000000000000..79f38386e651
--- /dev/null
+++ b/LICENSE.blas
@@ -0,0 +1,19 @@
+From: http://www.netlib.org/blas/faq.html
+
+ 2) Are there legal restrictions on the use of BLAS reference
+ implementation software?
+
+The reference BLAS is a freely-available software package. It is
+available from netlib via anonymous ftp and the World Wide Web. Thus,
+it can be included in commercial software packages (and has been). We
+only ask that proper credit be given to the authors.
+
+Like all software, it is copyrighted. It is not trademarked, but we do
+ask the following:
+
+If you modify the source for these routines we ask that you change the
+name of the routine and comment the changes made to the original.
+
+We will gladly answer any questions regarding the software. If a
+modification is done, however, it is the responsibility of the person
+who modified the routine to provide support.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..905f06820480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,85 @@
+# Maintainer: Thomas Mijieux <tom,tix?hotmail,fr>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: Jason Taylor <jftaylor21@gmail.com>
+
+pkgbase=lapack-tmg
+pkgname=('lapack-tmg' 'blas-tmg' 'cblas-tmg' 'lapacke-tmg')
+pkgver=3.7.0
+pkgrel=1
+url="http://www.netlib.org/lapack"
+pkgdesc="Linear Algebra PACKage with TMG lib"
+makedepends=('gcc-fortran' 'cmake' 'python')
+arch=('i686' 'x86_64')
+license=("custom")
+source=(http://www.netlib.org/lapack/lapack-${pkgver}.tgz LICENSE.blas)
+sha1sums=('27dbd06bedc76619150f8e28de6412f7df0c649a'
+ '2491a151a37f0162b25fc4e4e9a8ac444b574a76')
+
+build() {
+ install -d build
+ cd build
+ cmake ../lapack-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_TESTING=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_Fortran_COMPILER=gfortran \
+ -DLAPACKE=ON \
+ -DLAPACKE_WITH_TMG=ON \
+ -DCBLAS=ON \
+ -DBUILD_DEPRECATED=ON
+ make
+}
+
+package_lapack-tmg() {
+ depends=("blas-tmg")
+ conflicts=("lapack")
+ provides=("lapack")
+
+ cd build
+ make DESTDIR="$pkgdir" install
+
+ rm -r "$pkgdir"/usr/lib/{libblas.*,libcblas.*,liblapacke.*}
+ rm -r "$pkgdir"/usr/lib/pkgconfig/{blas.*,cblas.*,lapacke.*}
+ rm -r "$pkgdir"/usr/lib/cmake/{cblas*,lapacke*}
+ rm -r "$pkgdir"/usr/include
+}
+
+package_blas-tmg() {
+ pkgdesc="Basic Linear Algebra Subprograms"
+ depends=('gcc-libs')
+ conflicts=("blas")
+ provides=("blas")
+
+ cd build/BLAS
+ make DESTDIR="$pkgdir" install
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/blas"
+ install -m644 "${srcdir}/LICENSE.blas" \
+ "${pkgdir}/usr/share/licenses/blas/"
+}
+
+package_cblas-tmg() {
+ pkgdesc="C interface to BLAS"
+ depends=("blas-tmg")
+ conflicts=("cblas")
+ provides=("cblas")
+
+ cd build/CBLAS
+ make DESTDIR="$pkgdir" install
+}
+
+package_lapacke-tmg() {
+ pkgdesc="C interface to LAPACK"
+ depends=("lapack-tmg")
+ conflicts=("lapacke")
+ provides=("lapacke")
+
+ cd build/LAPACKE
+ make DESTDIR="$pkgdir" install
+}
+