summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-02-07 21:49:42 -0200
committerDaniel Bermond2018-02-07 21:55:12 -0200
commit9f62c6e1c8ea2e59f754e80e4f33200c30a5e1ab (patch)
treeb8d228f6ce110d2ba58c20b8d2eeeb810141c560
parent97b490e90d06abd73dd9dea9a850473b57c65c3c (diff)
downloadaur-9f62c6e1c8ea2e59f754e80e4f33200c30a5e1ab.tar.gz
Cosmetic and other small changes
- changed license from GPL2 to GPL (it includes the 'any later' statement) - remove 'bash' from depends (it is already part of the base group) - remove $pkgrel from the downloaded source file (not necessary)
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cb84d31e249..d344c6250fb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,10 @@
-# Generated by mksrcinfo v8
-# Wed Jan 18 12:55:06 UTC 2017
pkgbase = laptop-mode-tools
pkgdesc = Power Savings tool for Linux
pkgver = 1.71
- pkgrel = 1
- url = https://github.com/rickysarraf/laptop-mode-tools
+ pkgrel = 2
+ url = https://github.com/rickysarraf/laptop-mode-tools/
arch = any
- license = GPL2
- depends = bash
+ license = GPL
optdepends = acpid: ACPI support
optdepends = bluez-utils: Bluetooth support
optdepends = hdparm: hard disk power management
@@ -43,7 +40,7 @@ pkgbase = laptop-mode-tools
backup = etc/laptop-mode/conf.d/wireless-power.conf
backup = etc/laptop-mode/laptop-mode.conf
backup = etc/laptop-mode/lm-profiler.conf
- source = laptop-mode-tools-1.71-1.tar.gz::https://github.com/rickysarraf/laptop-mode-tools/archive/1.71.tar.gz
+ source = laptop-mode-tools-1.71.tar.gz::https://github.com/rickysarraf/laptop-mode-tools/archive/1.71.tar.gz
sha256sums = f69c870b07cafcb51df1cb5c25a8b349d1e1a2bd16b6ab33902aa3f8d1e3fa52
pkgname = laptop-mode-tools
diff --git a/PKGBUILD b/PKGBUILD
index a2212aaee9d2..1c1d721d5d51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
# Contributor: Lev Lybin <lev.lybin@gmail.com>
# Contributor: Aaditya Bagga <aaditya_gnulinux@zoho.com>
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
@@ -6,14 +7,11 @@
pkgname=laptop-mode-tools
pkgver=1.71
-pkgrel=1
+pkgrel=2
pkgdesc='Power Savings tool for Linux'
arch=('any')
-url='https://github.com/rickysarraf/laptop-mode-tools'
-source=(${pkgname}-${pkgver}-${pkgrel}.tar.gz::https://github.com/rickysarraf/laptop-mode-tools/archive/${pkgver}.tar.gz)
-sha256sums=('f69c870b07cafcb51df1cb5c25a8b349d1e1a2bd16b6ab33902aa3f8d1e3fa52')
-license=('GPL2')
-depends=('bash')
+url='https://github.com/rickysarraf/laptop-mode-tools/'
+license=('GPL')
optdepends=('acpid: ACPI support'
'bluez-utils: Bluetooth support'
'hdparm: hard disk power management'
@@ -49,14 +47,17 @@ backup=('etc/laptop-mode/conf.d/ac97-powersave.conf'
'etc/laptop-mode/conf.d/wireless-power.conf'
'etc/laptop-mode/laptop-mode.conf'
'etc/laptop-mode/lm-profiler.conf')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/rickysarraf/laptop-mode-tools/archive/${pkgver}.tar.gz")
+sha256sums=('f69c870b07cafcb51df1cb5c25a8b349d1e1a2bd16b6ab33902aa3f8d1e3fa52')
package() {
- cd "laptop-mode-tools-${pkgver}"
+ cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" MAN_D=/usr/share/man LIB_D=/usr/lib PREFIX=/usr INIT_D=false install
- # use /bin instead of /sbin
+ make DESTDIR="$pkgdir" MAN_D='/usr/share/man' LIB_D='/usr/lib' PREFIX='/usr' INIT_D='false' install
+
+ # use '/bin' instead of '/sbin'
mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
- find "${pkgdir}" -type f -exec sed -i 's|sbin/laptop_mode|bin/laptop_mode|g' '{}' ';'
+ find "$pkgdir" -type f -exec sed -i 's|sbin/laptop_mode|bin/laptop_mode|g' '{}' ';'
- install -Dm755 gui/LMT.py "${pkgdir}/usr/bin/lmt-gui"
+ install -D -m755 gui/LMT.py "${pkgdir}/usr/bin/lmt-gui"
}