summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwangjiezhe2016-02-22 22:04:28 +0800
committerwangjiezhe2016-02-22 22:04:28 +0800
commitea20e9168366086406a29a2b09aff4621e1eff08 (patch)
tree498cf4e78bdfcdbbc23800c817d9e0637c7b4eaa
downloadaur-ea20e9168366086406a29a2b09aff4621e1eff08.tar.gz
Initial import
-rw-r--r--.SRCINFO53
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD72
3 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36a3d6a77a04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,53 @@
+# Generated by mksrcinfo v8
+# Mon Feb 22 13:59:15 UTC 2016
+pkgbase = laptop-mode-tools-git
+ pkgdesc = Power Savings tool for Linux
+ pkgver = 1.68.1.27.gfaa613c
+ pkgrel = 1
+ url = https://github.com/rickysarraf/laptop-mode-tools
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = bash
+ optdepends = acpid: ACPI support
+ optdepends = bluez-utils: Bluetooth support
+ optdepends = hdparm: hard disk power management
+ optdepends = sdparm: SCSI disk power management
+ optdepends = ethtool: Ethernet support
+ optdepends = wireless_tools: Wi-Fi support
+ optdepends = xorg-xset: DPMS standby support
+ optdepends = python2-pyside: LMT GUI
+ provides = laptop-mode-tools
+ conflicts = laptop-mode-tools
+ backup = etc/laptop-mode/conf.d/ac97-powersave.conf
+ backup = etc/laptop-mode/conf.d/auto-hibernate.conf
+ backup = etc/laptop-mode/conf.d/battery-level-polling.conf
+ backup = etc/laptop-mode/conf.d/bluetooth.conf
+ backup = etc/laptop-mode/conf.d/configuration-file-control.conf
+ backup = etc/laptop-mode/conf.d/cpufreq.conf
+ backup = etc/laptop-mode/conf.d/dpms-standby.conf
+ backup = etc/laptop-mode/conf.d/eee-superhe.conf
+ backup = etc/laptop-mode/conf.d/ethernet.conf
+ backup = etc/laptop-mode/conf.d/exec-commands.conf
+ backup = etc/laptop-mode/conf.d/hal-polling.conf
+ backup = etc/laptop-mode/conf.d/intel-hda-powersave.conf
+ backup = etc/laptop-mode/conf.d/intel-sata-powermgmt.conf
+ backup = etc/laptop-mode/conf.d/lcd-brightness.conf
+ backup = etc/laptop-mode/conf.d/nmi-watchdog.conf
+ backup = etc/laptop-mode/conf.d/pcie-aspm.conf
+ backup = etc/laptop-mode/conf.d/runtime-pm.conf
+ backup = etc/laptop-mode/conf.d/sched-mc-power-savings.conf
+ backup = etc/laptop-mode/conf.d/sched-smt-power-savings.conf
+ backup = etc/laptop-mode/conf.d/start-stop-programs.conf
+ backup = etc/laptop-mode/conf.d/terminal-blanking.conf
+ backup = etc/laptop-mode/conf.d/video-out.conf
+ backup = etc/laptop-mode/conf.d/wireless-ipw-power.conf
+ backup = etc/laptop-mode/conf.d/wireless-iwl-power.conf
+ backup = etc/laptop-mode/conf.d/wireless-power.conf
+ backup = etc/laptop-mode/laptop-mode.conf
+ backup = etc/laptop-mode/lm-profiler.conf
+ source = laptop-mode-tools::git+https://github.com/rickysarraf/laptop-mode-tools.git
+ sha256sums = SKIP
+
+pkgname = laptop-mode-tools-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3a63ade817c8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*~
+\#*\#
+.\#*
+src/
+pkg/
+laptop-mode-tools
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ae90cc4f9ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,72 @@
+# Maintainer: wangjiezhe <wangjiezhe AT yandex DOT com>
+# Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
+# Contributor: Lev Lybin <lev.lybin@gmail.com>
+# Contributor: Aaditya Bagga <aaditya_gnulinux@zoho.com>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=laptop-mode-tools-git
+_pkgname=laptop-mode-tools
+pkgver=1.68.1.27.gfaa613c
+pkgrel=1
+pkgdesc='Power Savings tool for Linux'
+arch=('any')
+url='https://github.com/rickysarraf/laptop-mode-tools'
+source=("${_pkgname}::git+https://github.com/rickysarraf/laptop-mode-tools.git")
+sha256sums=('SKIP')
+license=('GPL2')
+depends=('bash')
+optdepends=('acpid: ACPI support'
+ 'bluez-utils: Bluetooth support'
+ 'hdparm: hard disk power management'
+ 'sdparm: SCSI disk power management'
+ 'ethtool: Ethernet support'
+ 'wireless_tools: Wi-Fi support'
+ 'xorg-xset: DPMS standby support'
+ 'python2-pyside: LMT GUI')
+backup=('etc/laptop-mode/conf.d/ac97-powersave.conf'
+ 'etc/laptop-mode/conf.d/auto-hibernate.conf'
+ 'etc/laptop-mode/conf.d/battery-level-polling.conf'
+ 'etc/laptop-mode/conf.d/bluetooth.conf'
+ 'etc/laptop-mode/conf.d/configuration-file-control.conf'
+ 'etc/laptop-mode/conf.d/cpufreq.conf'
+ 'etc/laptop-mode/conf.d/dpms-standby.conf'
+ 'etc/laptop-mode/conf.d/eee-superhe.conf'
+ 'etc/laptop-mode/conf.d/ethernet.conf'
+ 'etc/laptop-mode/conf.d/exec-commands.conf'
+ 'etc/laptop-mode/conf.d/hal-polling.conf'
+ 'etc/laptop-mode/conf.d/intel-hda-powersave.conf'
+ 'etc/laptop-mode/conf.d/intel-sata-powermgmt.conf'
+ 'etc/laptop-mode/conf.d/lcd-brightness.conf'
+ 'etc/laptop-mode/conf.d/nmi-watchdog.conf'
+ 'etc/laptop-mode/conf.d/pcie-aspm.conf'
+ 'etc/laptop-mode/conf.d/runtime-pm.conf'
+ 'etc/laptop-mode/conf.d/sched-mc-power-savings.conf'
+ 'etc/laptop-mode/conf.d/sched-smt-power-savings.conf'
+ 'etc/laptop-mode/conf.d/start-stop-programs.conf'
+ 'etc/laptop-mode/conf.d/terminal-blanking.conf'
+ 'etc/laptop-mode/conf.d/video-out.conf'
+ 'etc/laptop-mode/conf.d/wireless-ipw-power.conf'
+ 'etc/laptop-mode/conf.d/wireless-iwl-power.conf'
+ 'etc/laptop-mode/conf.d/wireless-power.conf'
+ 'etc/laptop-mode/laptop-mode.conf'
+ 'etc/laptop-mode/lm-profiler.conf')
+makedepends=('git')
+provides=('laptop-mode-tools')
+conflicts=('laptop-mode-tools')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe | sed 's/^v//;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ make DESTDIR="${pkgdir}" MAN_D=/usr/share/man LIB_D=/usr/lib PREFIX=/usr INIT_D=false install
+ # use /bin instead of /sbin
+ mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
+ find "${pkgdir}" -type f -exec sed -i 's|sbin/laptop_mode|bin/laptop_mode|g' '{}' ';'
+
+ install -Dm755 gui/LMT.py "${pkgdir}/usr/bin/lmt-gui"
+}