summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:10:13 +0100
committermschubert2015-06-12 12:10:13 +0100
commit883f1267426fe75412f3ca5c3487d5bb82e2e374 (patch)
tree6f3cbb1530d6c098433e2e45dd3c8f67ce4f29ab
downloadaur-883f1267426fe75412f3ca5c3487d5bb82e2e374.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba99a575c1ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = laspack
+ pkgdesc = Package for solving large sparse systems of linear equations.
+ pkgver = 1.12.2
+ pkgrel = 2
+ url = http://www.mgnet.org/mgnet/Codes/laspack/html/laspack.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ options = staticlibs
+ source = http://www.netlib.org/linalg/laspack.tgz
+ md5sums = fcfb3c86cc993e29eb477191b1136a8d
+
+pkgname = laspack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8b1f41746da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+# Contributor: Brice Méalier <mealier_brice@yahoo.fr>
+# Contributor: Stéphane Gaudreault <stephane.gaudreault@gmail.com>
+
+pkgname=laspack
+pkgver=1.12.2
+pkgrel=2
+pkgdesc="Package for solving large sparse systems of linear equations."
+url="http://www.mgnet.org/mgnet/Codes/laspack/html/laspack.html"
+license="GPL"
+arch=('i686' 'x86_64')
+source=("http://www.netlib.org/linalg/$pkgname.tgz")
+md5sums=('fcfb3c86cc993e29eb477191b1136a8d')
+options=('staticlibs')
+
+build() {
+ cd "$srcdir/$pkgname"
+ sed -i "s|/usr/local|$pkgdir/usr|g" makefile
+ make
+
+ cd "$srcdir/xc"
+ sed -i "s|/usr/local|$pkgdir/usr|g" makefile
+ make
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/{include,lib}
+
+ cd "$srcdir/$pkgname"
+ make install-local
+
+ cd "$srcdir/xc"
+ make install-local
+}