summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Ivačič2017-04-04 14:06:41 +0200
committerNikola Ivačič2017-04-04 14:06:41 +0200
commit4d35e1007be7f69d01e958ff907b696a458c8180 (patch)
treeb2ac240bd88966d212828dd91ae3cd1828f5f79e
downloadaur-4d35e1007be7f69d01e958ff907b696a458c8180.tar.gz
Initial commit for Lasso C library.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2929c18e1db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lasso
+ pkgdesc = Lasso is a free software C library aiming to implement the Liberty Alliance standards. ID-WSF and SAML 2.0.
+ pkgver = 2.5.1
+ pkgrel = 1
+ url = http://lasso.entrouvert.org/
+ arch = i686
+ arch = x86_64
+ license = GNU
+ makedepends = perl
+ makedepends = python-six
+ makedepends = jdk
+ depends = libxml2
+ depends = xmlsec
+ depends = openssl
+ source = https://dev.entrouvert.org/releases/lasso/lasso-2.5.1.tar.gz
+ sha512sums = f20bea62c04f3082d5c423f658bafe1bdde0012321c43092ed5d5a2c3ec7b21ec27d88d9fc630743fd7c99e767d9fd92b98de5d4f7d98c3a9e680717483daae1
+
+pkgname = lasso
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e6eacfcf1f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Nikola Ivačič <nikola.ivacic@dropchop.com>
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=lasso
+pkgver=2.5.1
+pkgrel=1
+pkgdesc="Lasso is a free software C library aiming to implement the Liberty Alliance standards. ID-WSF and SAML 2.0."
+arch=('i686' 'x86_64')
+url="http://lasso.entrouvert.org/"
+license=('GNU')
+depends=('libxml2' 'xmlsec' 'openssl')
+makedepends=('perl' 'python-six' 'jdk')
+source=("https://dev.entrouvert.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('f20bea62c04f3082d5c423f658bafe1bdde0012321c43092ed5d5a2c3ec7b21ec27d88d9fc630743fd7c99e767d9fd92b98de5d4f7d98c3a9e680717483daae1')
+
+build() {
+ cd "${pkgname}"-"${pkgver}"
+ ./configure --prefix=/usr
+ make CFLAGS="-g -O2 -w" CXXFLAGS="${CFLAGS}"
+}
+
+package() {
+ cd "${pkgname}"-"${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}