summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordbeley2019-09-26 21:55:30 +0200
committerdbeley2019-09-26 21:55:30 +0200
commit2235f7cc008aed6c2811a4f9b49b69e6e7886846 (patch)
treeebb28b7682dd4b6c73f14e2f52c878bae748e2fa
parentda0ccba033854b96368be718172a5e873d3b645b (diff)
downloadaur-2235f7cc008aed6c2811a4f9b49b69e6e7886846.tar.gz
Update PKGBUILD.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccc3a40c65e3..6c8db4588e7b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,7 @@ pkgbase = lastfm_cg-git
depends = python-pylast
depends = python-requests
depends = python-requests-cache
+ depends = python-tqdm
provides = lastfm_cg
conflicts = lastfm_cg
source = git+https://github.com/dbeley/lastfm_cg
diff --git a/PKGBUILD b/PKGBUILD
index 91c81aa78eb9..eb1061f41273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,10 +16,16 @@ depends=(
'python-pylast'
'python-requests'
'python-requests-cache'
+ 'python-tqdm'
)
source=("git+https://github.com/dbeley/${pkgname%-git}")
md5sums=("SKIP")
+build() {
+ cd "${pkgname%-git}"
+ python setup.py build
+}
+
package() {
cd "${pkgname%-git}"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1 --skip-build