summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Holfter2017-11-08 11:45:25 +0100
committerAdrian Holfter2017-11-08 11:45:25 +0100
commitbb82072dc1aa29b4a9a31d2d54779aa98e0208c7 (patch)
treec5e29ed3b85593b4b436993688afcd036d02c08b
downloadaur-bb82072dc1aa29b4a9a31d2d54779aa98e0208c7.tar.gz
initial commit based on laslib-git PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75f5e17a75a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Nov 8 10:45:03 UTC 2017
+pkgbase = lastools-git
+ pkgdesc = Efficient tools for LiDAR processing
+ pkgver = r653.20e9673
+ pkgrel = 1
+ url = http://lastools.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ provides = laslib
+ provides = lastools
+ conflicts = laslib
+ conflicts = lastools
+ source = git+https://github.com/LAStools/LAStools.git
+ md5sums = SKIP
+
+pkgname = lastools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aa8095f0ccc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Adrian Holfter < aholfter PLUS aur AT googlemail DOT com >
+pkgname=lastools-git
+pkgver=r653.20e9673
+pkgrel=1
+pkgdesc="Efficient tools for LiDAR processing"
+arch=('i686' 'x86_64')
+url="http://lastools.org/"
+license=('LGPL')
+provides=('laslib' 'lastools')
+conflicts=('laslib' 'lastools')
+source=("git+https://github.com/LAStools/LAStools.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "LAStools"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/LAStools"
+ make
+}
+
+package() {
+ # install LAStools binaries
+ cd "$srcdir/LAStools/bin"
+ binaries=(lasindex las2txt las2las txt2las lasdiff lasinfo laszip lasmerge lasprecision)
+ for binary in "${binaries[@]}"
+ do
+ install -Dm 755 "./$binary" "$pkgdir/usr/bin/$binary"
+ done
+
+ # LASzip include headers are needed, too
+ cd "$srcdir/LAStools/LASzip/src"
+ find . -iname "*.hpp" -exec install -Dm644 {} "$pkgdir/usr/include/laslib/{}" \;
+
+ # install LASlib include headers
+ cd "$srcdir/LAStools/LASlib/inc"
+ find . -exec install -Dm644 {} "$pkgdir/usr/include/laslib/{}" \;
+
+ # install library
+ cd "$srcdir/LAStools/LASlib/"
+ install -Dm644 "$srcdir/LAStools/LASlib/lib/liblas.a" "$pkgdir/usr/lib/liblaslib.a"
+}