summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2017-06-30 13:50:43 -0400
committerEli Schwartz2017-06-30 13:50:43 -0400
commit99ef5912a687882eaa5cc38fa063d1c5e529e1d2 (patch)
treec306c83f63f2c2beb219ae9a38872f4b67f0055b
parent0c947033b5899595bfdc9a19e8e352bff0bb82b9 (diff)
downloadaur-99ef5912a687882eaa5cc38fa063d1c5e529e1d2.tar.gz
upgpkg: lastpass 4.1.54a-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rwxr-xr-xtestupdate.sh20
3 files changed, 32 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eba4219333a..b3600633c61c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = lastpass
pkgdesc = The Universal LastPass installer for Firefox, Chrome, and Opera
- pkgver = 4.1.53
+ pkgver = 4.1.54a
pkgrel = 1
url = https://lastpass.com
arch = i686
arch = x86_64
license = custom
- optdepends = chromium
optdepends = firefox
+ optdepends = chromium
optdepends = google-chrome
optdepends = opera
- noextract = lastpass-4.1.53.xpi
+ noextract = lastpass-4.1.54a.xpi
noextract = lpchrome-4.1.52.crx
- source = lastpass-4.1.53.xpi::https://addons.mozilla.org/firefox/downloads/file/650260/
+ source = lastpass-4.1.54a.xpi::https://addons.mozilla.org/firefox/downloads/file/670270/
source = lpchrome-4.1.52.crx::https://lastpass.com/lpchrome_linux.crx
source = lplinux-4.1.44.tar.bz2::https://lastpass.com/lplinux.tar.bz2
source = com.lastpass.nplastpass.json
source = lastpass_policy_sources.json
source = lastpass_policy_install.json
source = License.txt
- sha256sums = 927a56376751e75e6bbfb29eec6a13defd06e991cfa79116bf2e8aaadb0b2c9d
+ sha256sums = 66a4b391e0cea5b0785967da19ab091c421393399d7c8e93631a0a3ba05c7dd8
sha256sums = 47937f48972b73f024a1e616547405d41e368cb3756f97958423d20d2196762d
sha256sums = adb0e91f8d212d34dbb85db0b11738fe36db1a741ad5674d7070c4019a9fc75e
sha256sums = e8eb3b585809d6644807727c5bd0a74ead96dd2c5a7e6d2ce29e0b6ea28b9e59
diff --git a/PKGBUILD b/PKGBUILD
index fc26128aa786..51b1aff486ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Eli Schwartz <eschwartz93@gmail.com>
pkgname=lastpass
-pkgver=4.1.53
+pkgver=4.1.54a
+pkgrel=1
_universalver=4.1.44
_chromever=4.1.52
-pkgrel=1
-_amo_file=650260
+_amo_file=670270
_crx_id=hdokiejnpimakedhajhdlcegeplioahd
pkgdesc="The Universal LastPass installer for Firefox, Chrome, and Opera"
arch=('i686' 'x86_64')
url="https://lastpass.com"
license=('custom')
-optdepends=('chromium'
- 'firefox'
+optdepends=('firefox'
+ 'chromium'
'google-chrome'
'opera')
# Apparently, API endpoints are all the rage -- so this isn't actually a file...
@@ -24,8 +24,8 @@ source=("${pkgname}-${pkgver}.xpi::https://addons.mozilla.org/firefox/downloads/
"lastpass_policy_install.json"
"License.txt")
noextract=("${pkgname}-${pkgver}.xpi"
-"lpchrome-${_chromever}.crx")
-sha256sums=('927a56376751e75e6bbfb29eec6a13defd06e991cfa79116bf2e8aaadb0b2c9d'
+ "lpchrome-${_chromever}.crx")
+sha256sums=('66a4b391e0cea5b0785967da19ab091c421393399d7c8e93631a0a3ba05c7dd8'
'47937f48972b73f024a1e616547405d41e368cb3756f97958423d20d2196762d'
'adb0e91f8d212d34dbb85db0b11738fe36db1a741ad5674d7070c4019a9fc75e'
'e8eb3b585809d6644807727c5bd0a74ead96dd2c5a7e6d2ce29e0b6ea28b9e59'
diff --git a/testupdate.sh b/testupdate.sh
new file mode 100755
index 000000000000..c126e2adf9e3
--- /dev/null
+++ b/testupdate.sh
@@ -0,0 +1,20 @@
+#!/bin/bash
+
+source /usr/share/makepkg/util/message.sh
+colorize
+
+if [[ $1 = beta ]]; then
+ checkbeta=beta
+fi
+
+
+download_url="$(curl -s https://addons.mozilla.org/en-us/firefox/addon/lastpass-password-manager/versions/"$checkbeta"|grep 'downloads/file'|tac|tee /dev/stderr|tail -1)"
+file="$(echo "$download_url"|sed -r 's@.*file/([0-9]+)/.*@\1@g')"
+version="$(echo "$download_url"|sed -r 's@.*lastpass_password_manager-([0-9a-z.]+)-.*@\1@g')"
+
+msg2 "pkgver=$version"
+msg2 "_file=$file"
+
+if echo "$download_url"|grep -qs data-realurl; then
+ error "Not yet reviewed"
+fi