summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2014-10-24 00:00:07 +0000
committerEli Schwartz2015-11-11 21:12:13 -0500
commit0cdef01d0e999467816dc16766611004a7260bcf (patch)
treef51c3c32e2de991c6f453797c49032db32332b3d
downloadaur-0cdef01d0e999467816dc16766611004a7260bcf.tar.gz
Imported old history from aur-mirror:
updated on Fri Oct 24 00:00:06 UTC 2014 filter-branch: add .SRCINFO
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77bc946d4de6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lastpass-cli-git
+ pkgdesc = LastPass command line interface tool (git version)
+ pkgver = 2014.10.22.g70acc1b
+ pkgrel = 1
+ url = https://lastpass.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = asciidoc
+ depends = openssl
+ depends = curl
+ depends = libxml2
+ optdepends = xclip: clipboard support
+ optdepends = pinentry: securelly read passwords
+ source = git+https://github.com/lastpass/lastpass-cli.git
+ md5sums = SKIP
+
+pkgname = lastpass-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5622fdefc23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Thiago Perrotta <echo dGhpYWdvcGVycm90dGE5NUBnbWFpbC5jb20K | base64 -d >
+
+_gitname=lastpass-cli
+pkgname=lastpass-cli-git
+pkgver=2014.10.22.g70acc1b
+pkgrel=1
+pkgdesc="LastPass command line interface tool (git version)"
+arch=('i686' 'x86_64')
+url="https://lastpass.com/"
+license=('GPL2')
+depends=('openssl' 'curl' 'libxml2')
+makedepends=('asciidoc')
+optdepends=('xclip: clipboard support'
+ 'pinentry: securelly read passwords')
+source=("git+https://github.com/lastpass/${_gitname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ make all doc
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ make DESTDIR="${pkgdir}/" install install-doc
+}
+
+# vim:set ts=2 sw=2 et: