summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2015-11-11 21:12:33 -0500
committerEli Schwartz2015-11-11 21:12:33 -0500
commit8252ef22e4820b4573a83be7d2b538053f3274f5 (patch)
tree00dc76f8862cef397e7b0f96c90b6907038b25c0
parent69ca3c910e7d0b3f84e1e665189f0eb313f52d55 (diff)
downloadaur-8252ef22e4820b4573a83be7d2b538053f3274f5.tar.gz
upgpkg: lastpass-cli-git 0.6.0.r25.gf2acef6-1
Adopt package, Schwartzify
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df9433055c37..0e1561a2d276 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lastpass-cli-git
pkgdesc = LastPass command line interface tool (git version)
- pkgver = 2014.10.22.g70acc1b
+ pkgver = 0.6.0.r25.gf2acef6
pkgrel = 1
url = https://lastpass.com/
arch = i686
@@ -12,8 +12,8 @@ pkgbase = lastpass-cli-git
depends = curl
depends = libxml2
optdepends = xclip: clipboard support
- optdepends = pinentry: securelly read passwords
- source = git+https://github.com/lastpass/lastpass-cli.git
+ optdepends = pinentry: securely read passwords
+ source = git://github.com/lastpass/lastpass-cli.git
md5sums = SKIP
pkgname = lastpass-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 2eb2385d2f5c..5aacf87d02e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Thiago Perrotta <echo dGhpYWdvcGVycm90dGE5NUBnbWFpbC5jb20K | base64 -d >
+# Maintainer: Eli Schwartz <eschwartz93@gmail.com>
+# Contributor: Thiago Perrotta <echo dGhpYWdvcGVycm90dGE5NUBnbWFpbC5jb20K | base64 -d >
-_gitname=lastpass-cli
pkgname=lastpass-cli-git
-pkgver=2014.10.22.g70acc1b
+pkgver=0.6.0.r25.gf2acef6
pkgrel=1
pkgdesc="LastPass command line interface tool (git version)"
arch=('i686' 'x86_64')
@@ -11,23 +11,21 @@ license=('GPL2')
depends=('openssl' 'curl' 'libxml2')
makedepends=('asciidoc' 'git')
optdepends=('xclip: clipboard support'
- 'pinentry: securelly read passwords')
-source=("git+https://github.com/lastpass/${_gitname}.git")
+ 'pinentry: securely read passwords')
+source=("git://github.com/lastpass/${pkgname%-git}.git")
md5sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- git log -1 --format="%cd.g%h" --date=short | sed 's/-/./g'
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${pkgname%-git}"
make all doc
}
package() {
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${pkgname%-git}"
make DESTDIR="${pkgdir}/" install install-doc
}
-
-# vim:set ts=2 sw=2 et: