summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-08-24 17:06:39 +0100
committerHans-Nikolai Viessmann2016-08-24 17:06:39 +0100
commit0ddf1d470f84a5a7d88cc34b998858a623dd11c9 (patch)
tree7163486da5d91f8a6881e72c5875aaa3503857ff
downloadaur-0ddf1d470f84a5a7d88cc34b998858a623dd11c9.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--latex-ocr-a-font.install12
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af84dd5d0fb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = latex-ocr-a-font
+ pkgdesc = Provides Type 1 fonts of the OCR-A typeface.
+ pkgver = 1.00
+ pkgrel = 1
+ url = http://www.ctan.org/tex-archive/fonts/ocr-a/
+ install = latex-ocr-a-font.install
+ arch = any
+ license = custom:CTAN-NoSell
+ depends = texlive-core
+ source = http://mirrors.ctan.org/fonts/ocr-a.zip
+ source = LICENSE::http://texcatalogue.ctan.org/licenses.nosell.html
+ md5sums = 67ce5623c064cda47dbd349a351c1a4a
+ md5sums = 6511a45b4d21ddf87726c16caf8e8ef4
+
+pkgname = latex-ocr-a-font
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..136ea679636a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 @ hw.ac.uk>
+_pkgname=ocr-a
+pkgname=latex-${_pkgname}-font
+pkgver=1.00
+pkgrel=1
+pkgdesc="Provides Type 1 fonts of the OCR-A typeface."
+arch=('any')
+url="http://www.ctan.org/tex-archive/fonts/ocr-a/"
+license=('custom:CTAN-NoSell')
+depends=('texlive-core')
+install="${pkgname}.install"
+source=("http://mirrors.ctan.org/fonts/${_pkgname}.zip"
+ "LICENSE::http://texcatalogue.ctan.org/licenses.nosell.html")
+md5sums=('67ce5623c064cda47dbd349a351c1a4a'
+ '6511a45b4d21ddf87726c16caf8e8ef4')
+
+prepare() {
+ cd "$_pkgname"
+
+ # We need to fix a distribution-related problem
+ sed 's/input ocra/input ocr-a/' -i ocr10.mf ocr12.mf ocr16.mf
+}
+
+package() {
+ install -d ${pkgdir}/usr/share/texmf/fonts/source/public
+ cp -r ${_pkgname} ${pkgdir}/usr/share/texmf/fonts/source/public/
+
+ # lets not forget the license
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
diff --git a/latex-ocr-a-font.install b/latex-ocr-a-font.install
new file mode 100644
index 000000000000..d6225b91c3d9
--- /dev/null
+++ b/latex-ocr-a-font.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_remove
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}