summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2015-06-12 12:09:28 +0100
committermschubert2015-06-12 12:09:28 +0100
commit42cb473a5b314740b7dfc888a4e8c9a957894af8 (patch)
treed33d9201d2e62e5a532799827c6aeb76a49025a0
downloadaur-42cb473a5b314740b7dfc888a4e8c9a957894af8.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--latex-pdfpages.install13
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..128f70960186
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = latex-pdfpages
+ pkgdesc = Inclusion of external multi-page PDF documents in LATEX documents
+ pkgver = 0.4v
+ pkgrel = 1
+ url = http://www.ctan.org/tex-archive/macros/latex/contrib/pdfpages
+ install = latex-pdfpages.install
+ arch = any
+ license = unknown
+ depends = texlive-core
+ noextract = pdfpages.zip
+ source = http://mirror.ctan.org/macros/latex/contrib/pdfpages.zip
+ md5sums = 546702540a13f7f85fefd7ec68332f89
+
+pkgname = latex-pdfpages
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..905f2e3ee068
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+
+pkgname=latex-pdfpages
+_pkgname=${pkgname#latex-}
+pkgver=0.4v
+pkgrel=1
+pkgdesc="Inclusion of external multi-page PDF documents in LATEX documents"
+arch=('any')
+url="http://www.ctan.org/tex-archive/macros/latex/contrib/pdfpages"
+license=('unknown')
+depends=('texlive-core')
+noextract=("$_pkgname.zip")
+source=("http://mirror.ctan.org/macros/latex/contrib/$_pkgname.zip")
+install="$pkgname.install"
+md5sums=('546702540a13f7f85fefd7ec68332f89')
+
+package() {
+ TEXMF="/usr/share/texmf"
+
+ mkdir -p "$pkgdir/$TEXMF"
+ unzip -d "$pkgdir/$TEXMF/tex" "$_pkgname.zip"
+}
+
diff --git a/latex-pdfpages.install b/latex-pdfpages.install
new file mode 100644
index 000000000000..47445e33c217
--- /dev/null
+++ b/latex-pdfpages.install
@@ -0,0 +1,13 @@
+post_install() {
+ mktexlsr
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+