summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212023-11-24 13:35:39 +0100
committera8212023-11-24 13:37:25 +0100
commit4e2482e86ffdf5ded133364591fba6b678513cc5 (patch)
tree4eec85cdadf91460e025ae808de07f36f9a0a09f
parent983c9440d27da711e7dce594964d5592d17a8f29 (diff)
downloadaur-latex-template-pss.tar.gz
Fix PKBUILD
* Put the files in the correct dirs * Fix dependencies * Put extra files in "docs" * Remove unneeded `install` file (pacman hooks takes care) * Remove empty vars and quote "$pkgdir"
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
-rw-r--r--texlive.install17
3 files changed, 19 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c65cb30ef913..518e530ef34b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = latex-template-pss
pkgdesc = LaTeX template for the physica status solidi journal
pkgver = 2
- pkgrel = 1
- url = https://www.wiley-vch.de/publish/en/journals/alphabeticIndex/2133/?jURL=http://www.wiley-vch.de:80/vch/journals/2133/2133_authors.html
- install = texlive.install
+ pkgrel = 2
+ url = https://www.wiley-vch.de/en/shop/journals/212
arch = any
- makedepends = unzip
- depends = texlive-basic
+ license = unknown
+ depends = texlive-latexrecommended
+ depends = texlive-fontsrecommended
source = https://www.wiley-vch.de/vch/journals/2133/public/pss_template_latex.zip
- md5sums = 570b8eb99f55e4c01aa397dd49745d35
+ sha256sums = 70660a55990eeb9c9d12deca1319020d80642c43cfdee5fd09b8a077c478f9a2
pkgname = latex-template-pss
diff --git a/PKGBUILD b/PKGBUILD
index 223f8e79660f..802fb4d46e8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,22 @@
-# Maintainer: knedl1k <knedl1k at duck dot com>
+# Contributor: knedl1k <knedl1k at duck dot com>
# Contributor: Jan Oliver Oelerich <jan.oliver.oelerich@physik.uni-marburg.de>
pkgname=latex-template-pss
pkgver=2
-pkgrel=1
+pkgrel=2
pkgdesc="LaTeX template for the physica status solidi journal"
arch=('any')
-url="https://www.wiley-vch.de/publish/en/journals/alphabeticIndex/2133/?jURL=http://www.wiley-vch.de:80/vch/journals/2133/2133_authors.html"
-license=()
-groups=()
-depends=('texlive-basic')
-makedepends=('unzip')
-optdepends=()
-backup=()
-install=texlive.install
-options=()
-source=(https://www.wiley-vch.de/vch/journals/2133/public/pss_template_latex.zip)
-md5sums=('570b8eb99f55e4c01aa397dd49745d35')
-
+url="https://www.wiley-vch.de/en/shop/journals/212"
+license=('unknown')
+depends=('texlive-latexrecommended' 'texlive-fontsrecommended')
+source=("https://www.wiley-vch.de/vch/journals/2133/public/pss_template_latex.zip")
+sha256sums=('70660a55990eeb9c9d12deca1319020d80642c43cfdee5fd09b8a077c478f9a2')
package(){
- cd ${srcdir}/PSS_latex
- install -m 0644 -D readme.txt ${pkgdir}/usr/share/texmf-dist/tex/latex/pss/readme.txt
- install -m 0644 -D wiley2sp.cls ${pkgdir}/usr/share/texmf-dist/tex/latex/pss/wiley2sp.cls
- install -m 0644 -D w2sp-pss.clo ${pkgdir}/usr/share/texmf-dist/tex/latex/pss/w2sp-pss.clo
- install -m 0644 -D pss.bst ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/pss.bst
- install -m 0644 -D caption.sty ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/caption.sty
- install -m 0644 -D caption3.sty ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/caption3.sty
- install -m 0644 -D subfig.sty ${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss/subfig.sty
+ cd PSS_latex
+ install -Dm644 -t "${pkgdir}/usr/share/texmf-dist/tex/latex/pss" wiley2sp.cls w2sp-pss.clo
+ install -Dm644 -t "${pkgdir}/usr/share/texmf-dist/bibtex/bst/pss" pss.bst
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" readme.txt \
+ pss_demo.pdf pss_demo.tex pss_demo.bib \
+ empty2h.eps empty2h.pdf empty2w.eps empty2w.pdf
}
diff --git a/texlive.install b/texlive.install
deleted file mode 100644
index 6b32f29f92da..000000000000
--- a/texlive.install
+++ /dev/null
@@ -1,17 +0,0 @@
-# $Id: texlive.install 149 2009-04-30 00:46:23Z shtrom $
-# Taken from texlive-publishers
-
-post_install() {
- echo ">>> texlive: updating the filename database..."
- texconfig-sys rehash
-}
-
-post_upgrade() {
- echo ">>> texlive: updating the filename database..."
- texconfig-sys rehash
-}
-
-post_remove() {
- echo ">>> texlive: updating the filename database..."
- texconfig-sys rehash
-}