summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2023-08-18 08:17:02 +0200
committergit user2023-08-18 08:17:02 +0200
commited6c3f3f4d8734985eb2273a732cff48aa5df91c (patch)
tree1de5cccdf32925ca2486e64e6d8ebcf8635e4258
parent2098ccbf732f8ee60a47e94cea2a3a87460dc49d (diff)
downloadaur-ed6c3f3f4d8734985eb2273a732cff48aa5df91c.tar.gz
Fixed reported issues except the missing `mathtex` dependency.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD44
2 files changed, 36 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4d123637ac8..05d0e129f746 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = latextogrob
- pkgdesc = A simple script to convert a file with LaTeX formulae into a readable file with HP 50g
+ pkgdesc = A simple script to convert a file with LaTeX formulae into a readable file with HP 48/50g
pkgver = 0.2
- pkgrel = 1
+ pkgrel = 2
url = https://bbs.archlinux.org/viewtopic.php?id=117953
arch = any
- license = GPL
- depends = mathtex
+ license = GPL2
+ depends = bash
depends = imagemagick
+ depends = mathtex
+ depends = netpbm
depends = pgmtogrob
source = latextogrob
- md5sums = 0c4f966caae11a58387b836814760070
+ sha256sums = 458713f368cd6b4ba0b6081f338aaa75dc61cb0b8f9a725d1b292d1bb5f1fb3a
pkgname = latextogrob
-
diff --git a/PKGBUILD b/PKGBUILD
index 9601c5207e5b..5846accce596 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,30 @@
-# Contributor: Adria Arrufat <swiftscythe@gmail.com>
- pkgname=latextogrob
- pkgver=0.2
- pkgrel=1
- pkgdesc="A simple script to convert a file with LaTeX formulae into a readable file with HP 50g"
- arch=('any')
- url=("https://bbs.archlinux.org/viewtopic.php?id=117953")
- license=("GPL")
- depends=('mathtex' 'imagemagick' 'pgmtogrob')
- source=('latextogrob')
- md5sums=('0c4f966caae11a58387b836814760070')
+# Maintainer: (dreieck https://aur.archlinux.org/account/dreieck)
+# Contributor: Adria Arrufat
+# Contributor: swiftcythe (https://aur.archlinux.org/account/swiftscythe)
- build() {
- cd $srcdir/
- install -D -m755 $pkgname $pkgdir/usr/bin/$pkgname || return 1
- }
+pkgname='latextogrob'
+pkgver=0.2
+pkgrel=2
+pkgdesc="A simple script to convert a file with LaTeX formulae into a readable file with HP 48/50g"
+arch=('any')
+url="https://bbs.archlinux.org/viewtopic.php?id=117953"
+license=("GPL2")
+depends=(
+ 'bash'
+ 'imagemagick'
+ 'mathtex'
+ 'netpbm'
+ 'pgmtogrob'
+)
+source=(
+ 'latextogrob'
+)
+sha256sums=(
+ '458713f368cd6b4ba0b6081f338aaa75dc61cb0b8f9a725d1b292d1bb5f1fb3a'
+)
+
+package() {
+ cd "${srcdir}"
+
+ install -Dvm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}