summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-14 07:37:39 -0400
committerChris Severance2015-09-14 07:37:39 -0400
commitd73d46e1942e4f4054e38b515b92f9dd047eaf03 (patch)
tree61fea81aa6354ffd056560c1dc8a2752d3e6d8e0
downloadaur-d73d46e1942e4f4054e38b515b92f9dd047eaf03.tar.gz
Initial Import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46cdba8221b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = latrace
+ pkgdesc = trace library calls and get their statistics in a manner similar to the strace utility (syscall tracing)
+ pkgver = 0.5.11
+ pkgrel = 2
+ url = http://people.redhat.com/jolsa/latrace/index.shtml
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = asciidoc
+ depends = glibc
+ source = http://people.redhat.com/jolsa/latrace/dl/latrace-0.5.11.tar.bz2
+ sha256sums = 3b5afacafa8c1f9f00fb911466f4e2944162aaedfd81805f54e34c22652dbdd5
+
+pkgname = latrace
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e70986cf85cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: philomath <philomath868 AT gmail DOT com>
+# Contributor: Sebastien Binet <binet@farnsworth>
+
+set -u
+pkgname='latrace'
+pkgver='0.5.11'
+pkgrel='2'
+pkgdesc='trace library calls and get their statistics in a manner similar to the strace utility (syscall tracing)'
+arch=('i686' 'x86_64')
+url='http://people.redhat.com/jolsa/latrace/index.shtml'
+license=('GPL3')
+depends=('glibc')
+makedepends=('asciidoc')
+_verwatch=("http://people.redhat.com/jolsa/${pkgname}/download.shtml" "dl/${pkgname}-\([0-9\.]\+\)\.tar\.bz2" 'l')
+source=("http://people.redhat.com/jolsa/latrace/dl/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('3b5afacafa8c1f9f00fb911466f4e2944162aaedfd81805f54e34c22652dbdd5')
+
+prepare() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ aclocal
+ autoconf
+ ./configure --prefix='/usr' --sysconfdir='/etc'
+ set +u
+}
+
+build() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ make -s -j "$(nproc)"
+ set +u
+}
+
+package() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+ set +u
+}
+set +u