summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpoilojointur2021-12-11 21:22:42 -0500
committerpoilojointur2021-12-11 21:24:16 -0500
commitef482ce952021f946ca54928b32c6428d2e94f68 (patch)
tree8bd9eb1cdf1ab95a4f07b726d544b224ed4eda89
downloadaur-ef482ce952021f946ca54928b32c6428d2e94f68.tar.gz
initial commit for lattice-radiant package
-rw-r--r--.SRCINFO56
-rw-r--r--PKGBUILD61
-rw-r--r--lattice-radiant.desktop9
-rw-r--r--lattice-radiant.install8
-rw-r--r--lattice-radiant.pngbin0 -> 2371 bytes
5 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ad5d303b54c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,56 @@
+pkgbase = lattice-radiant
+ pkgdesc = Lattice Radiant design software
+ pkgver = 3.0.0.24.1
+ pkgrel = 1
+ url = http://www.latticesemi.com/
+ install = lattice-radiant.install
+ arch = x86_64
+ license = custom
+ depends = fontconfig
+ depends = gnu-free-fonts
+ depends = nss
+ depends = atk
+ depends = cairo
+ depends = pango
+ depends = pulseaudio
+ depends = libxcb
+ depends = xcb-util
+ depends = xcb-util-image
+ depends = xcb-util-keysyms
+ depends = xcb-util-renderutil
+ depends = xcb-util-wm
+ depends = glibc
+ depends = libjpeg
+ depends = libieee1284
+ depends = libusb
+ depends = libx11
+ depends = libice
+ depends = libsm
+ depends = libxt
+ depends = libxtst
+ depends = libxext
+ depends = libxrender
+ depends = libxi
+ depends = libxft
+ depends = libxkbcommon
+ depends = libxkbcommon-x11
+ depends = libxslt
+ depends = libxrandr
+ depends = libxfixes
+ depends = libxdamage
+ depends = libxcursor
+ depends = libxcomposite
+ depends = libgl
+ depends = libxinerama
+ depends = libxss
+ options = !strip
+ source = http://files.latticesemi.com/Radiant/3.0.0.24.1_Radiant_lin.zip
+ source = lattice-radiant.install
+ source = lattice-radiant.png
+ source = lattice-radiant.desktop
+ sha512sums = 1337d32401ee66ed31c880d4357f048195545f1166a8de11d5601fe686e03cb7e53a8d28fa78dd125bb342f7fa4bde43419c975d32e144342e17b4045c62e083
+ sha512sums = 7ca5af62d5fd5cf9d0ead8c4f84bba42389340192a5a2648fc06b2674ec43b3dd060ec4aecb91f75eff7d74e2b2c630c24119ff93a81ab4e3e32b9551a6d2e68
+ sha512sums = 878dea16b7bc634e2bc64ddf7ea9a1ad40fa7dfbad000003a8a6737d7da557d7dd38281e885691a39db0009605393f9598e2f94f8ea541eca5489d41e5ae6a66
+ sha512sums = 9545ef1d8ab220b2e3497d7ee7de06163c0723a5bab960ccd810dee050e3b9669ed8496f122a1c1a020192795bd02ea466b6db6081bd6aeb913c4d3a9db16645
+
+pkgname = lattice-radiant
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e2922e121eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: poilojointur <poilojointur@hotmail.com>
+#
+# Note: If downloads do not work (fail with e.g. error 403), you will have
+# to manually download the base package and the latest service pack from
+# http://files.latticesemi.com/Radiant/3.0.0.24.1_Radiant_lin.zip
+# Then put these files in the build directory and retry.
+
+_version=3.0.0.24.1
+pkgname=lattice-radiant
+pkgdesc='Lattice Radiant design software'
+url=http://www.latticesemi.com/
+license=('custom')
+pkgver=${_version}
+pkgrel=1
+arch=('x86_64')
+install=$pkgname.install
+
+source=("http://files.latticesemi.com/Radiant/${_version}_Radiant_lin.zip"
+ "lattice-radiant.install"
+ "lattice-radiant.png"
+ "lattice-radiant.desktop")
+
+sha512sums=('1337d32401ee66ed31c880d4357f048195545f1166a8de11d5601fe686e03cb7e53a8d28fa78dd125bb342f7fa4bde43419c975d32e144342e17b4045c62e083'
+ '7ca5af62d5fd5cf9d0ead8c4f84bba42389340192a5a2648fc06b2674ec43b3dd060ec4aecb91f75eff7d74e2b2c630c24119ff93a81ab4e3e32b9551a6d2e68'
+ '878dea16b7bc634e2bc64ddf7ea9a1ad40fa7dfbad000003a8a6737d7da557d7dd38281e885691a39db0009605393f9598e2f94f8ea541eca5489d41e5ae6a66'
+ '9545ef1d8ab220b2e3497d7ee7de06163c0723a5bab960ccd810dee050e3b9669ed8496f122a1c1a020192795bd02ea466b6db6081bd6aeb913c4d3a9db16645')
+
+# These run-time dependencies seem to be needed for proper operation
+depends=(
+ 'fontconfig' 'gnu-free-fonts' 'nss' 'atk' 'cairo' 'pango' 'pulseaudio'
+ 'libxcb' 'xcb-util' 'xcb-util-image' 'xcb-util-keysyms' 'xcb-util-renderutil' 'xcb-util-wm'
+ 'glibc' 'libjpeg' 'libieee1284' 'libusb' 'libx11' 'libice' 'libsm' 'libxt' 'libxtst' 'libxext' 'libxrender' 'libxi' 'libxft'
+ 'libxkbcommon' 'libxkbcommon-x11' 'libxslt' 'libxrandr' 'libxfixes' 'libxdamage' 'libxcursor' 'libxcomposite' 'libgl' 'libxinerama' 'libxss'
+ )
+
+options=('!strip')
+PKGEXT=".pkg.tar.zst"
+
+prepare() {
+ # Unzip and run the self extracting executable
+ echo "Extracting archive..."
+ bsdtar -xf ${_version}_Radiant_lin.zip
+ echo "Running Lattice Radiant Installer"
+ ./${_version}_Radiant_lin.run --console --prefix usr/local/radiant/${_version}
+}
+
+package() {
+ # Move everything to pkgdir
+ mv ${srcdir}/usr ${pkgdir}/
+
+ # Remove uninstaller and install logs since we have a working package management
+ rm -r "${pkgdir}/usr/local/radiant/3.0.0.24.1/uninstaller.dat"
+ rm -r "${pkgdir}/usr/local/radiant/3.0.0.24.1/InstallationLog.txt"
+
+ # Copy license file
+ install -D -m644 "${pkgdir}/usr/local/radiant/3.0.0.24.1/data/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Install integration files
+ install -D -m644 lattice-radiant.png "${pkgdir}/usr/share/pixmaps/lattice-radiant.png"
+ install -D -m644 lattice-radiant.desktop "${pkgdir}/usr/share/applications/lattice-radiant.desktop"
+}
diff --git a/lattice-radiant.desktop b/lattice-radiant.desktop
new file mode 100644
index 000000000000..6439f26cb7e3
--- /dev/null
+++ b/lattice-radiant.desktop
@@ -0,0 +1,9 @@
+#!/usr/bin/env xdg-open
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=lattice-radiant
+Name=Lattice Radiant
+Exec=/usr/local/radiant/3.0.0.24.1/bin/lin64/radiant
+Categories=Development;
+Comment=Lattice Radiant Design Software
diff --git a/lattice-radiant.install b/lattice-radiant.install
new file mode 100644
index 000000000000..2945ab3cceb8
--- /dev/null
+++ b/lattice-radiant.install
@@ -0,0 +1,8 @@
+pre_install() {
+ echo 'WARNING: By installing this package, you agree to its license terms!'
+}
+
+post_upgrade() {
+ echo 'WARNING: If you had a license file in /usr/local/radiant/<version>/license/license.dat, it will not be automatically removed.'
+ echo 'You can manually delete or move it to the new install directory.'
+}
diff --git a/lattice-radiant.png b/lattice-radiant.png
new file mode 100644
index 000000000000..63e6ba7fb2dd
--- /dev/null
+++ b/lattice-radiant.png
Binary files differ