summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 06:40:43 -0600
committerBrian Bidulock2015-06-10 06:40:43 -0600
commitb53ca9b22ed2e35816b1f6dd4c28799c40168e36 (patch)
tree8a154f6c1dd097adb2d65704db8f0537a643d712
downloadaur-b53ca9b22ed2e35816b1f6dd4c28799c40168e36.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c0f344e89e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = launch
+ pkgdesc = Launch.app is a small programm for executing applications, based on WINGs library.
+ pkgver = 1.0pre1
+ pkgrel = 2
+ url = http://stepmaker.sourceforge.net/launch.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = windowmaker
+ options = !buildflags
+ source = http://downloads.sourceforge.net/sourceforge/stepmaker/Launch.app-1.0pre1.tar.gz
+ md5sums = 9b51931c7eefd618348bfd2b2b10a7a7
+
+pkgname = launch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..454c10016cfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Daniel Isenmann <daniel.isenmann [at] gmx.de>
+pkgname=launch
+_pkgname='Launch.app'
+pkgver=1.0pre1
+pkgrel=2
+pkgdesc="Launch.app is a small programm for executing applications, based on WINGs library."
+url="http://stepmaker.sourceforge.net/launch.html"
+arch=('i686' 'x86_64')
+license="GPL"
+depends=('windowmaker')
+options=('!buildflags')
+source=("http://downloads.sourceforge.net/sourceforge/stepmaker/$_pkgname-$pkgver.tar.gz")
+md5sums=('9b51931c7eefd618348bfd2b2b10a7a7')
+
+build() {
+ cd "$srcdir/Launch"
+ make
+}
+package() {
+ cd "$srcdir/Launch"
+ make PREFIX="$pkgdir/usr/lib/GNUstep/Applications/$_pkgname" install
+}