summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDiab Neiroukh2020-04-04 18:17:38 +0100
committerDiab Neiroukh2020-04-04 18:19:34 +0100
commitac86c829adbfac1591c2cded7f1e0a8cebd303ef (patch)
tree11d06c25d17719e9426c2d0d64f0743309740399
downloadaur-ac86c829adbfac1591c2cded7f1e0a8cebd303ef.tar.gz
🔥
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..886ae63d44c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = layan-cursor-theme-git
+ pkgdesc = A x-cursor theme inspired by layan gtk theme and based on capitaine-cursors.
+ pkgver = 0.0.0.7a37de2
+ pkgrel = 1
+ url = https://github.com/vinceliuice/Layan-cursors
+ arch = any
+ license = GPL3
+ makedepends = git
+ provides = layan-cursor-theme
+ conflicts = layan-cursor-theme
+ source = git+https://github.com/vinceliuice/Layan-cursors.git
+ sha256sums = SKIP
+
+pkgname = layan-cursor-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c2c88eb5585
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
+
+pkgname=layan-cursor-theme-git
+_reponame='Layan-cursors'
+pkgver=0.0.0.7a37de2
+pkgrel=1
+pkgdesc='A x-cursor theme inspired by layan gtk theme and based on capitaine-cursors.'
+arch=("any")
+provides=("layan-cursor-theme")
+conflicts=("layan-cursor-theme")
+url="https://github.com/vinceliuice/${_reponame}"
+license=("GPL3")
+makedepends=("git")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd "${srcdir}/${_reponame}"
+ if [ $(git tag|wc -l) == 0 ]; then
+ echo "0.0.0.$(git log -1 --format='%h')"
+ else
+ git describe --tags | sed 's/-/.r/; s/-g/./'
+ fi
+}
+
+package() {
+ dst="${pkgdir}/usr/share/icons"
+ mkdir -p "${dst}"
+ cd "${srcdir}/${_reponame}"
+ UID=0 ./install.sh
+}