summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrebel2017-10-23 10:13:18 +0200
committerrebel2017-10-23 10:13:18 +0200
commit42b230f1d921eb552d5cf84f46f533a507d9e8f4 (patch)
tree608879e9d9e0aa884356961ab2f35c6bf8e162eb
downloadaur-42b230f1d921eb552d5cf84f46f533a507d9e8f4.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3dc9a264777
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lazarus-svn
+ pkgdesc = Delphi-like build environment for FreePascal
+ pkgver = 1.9
+ pkgrel = 1
+ url = https://www.lazarus-ide.org/
+ arch = x86_64
+ license = LGPL3
+ makedepends = subversion
+ depends = fpc
+ depends = fpc-src
+ provides = lazarus
+ conflicts = lazarus
+ source = lazarus-svn::svn+https://svn.freepascal.org/svn/lazarus/trunk
+ sha256sums = SKIP
+
+pkgname = lazarus-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eac05a30de08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: rebel <novakpetya at yahoo dot co dot uk>
+
+pkgname=lazarus-svn
+pkgver=1.9
+pkgrel=1
+pkgdesc="Delphi-like build environment for FreePascal"
+arch=(x86_64)
+url=https://www.lazarus-ide.org/
+license=(LGPL3)
+conflicts=(lazarus)
+depends=(fpc fpc-src)
+makedepends=(subversion)
+provides=(lazarus)
+source=("$pkgname::svn+https://svn.freepascal.org/svn/lazarus/trunk")
+
+build() {
+ cd $pkgname
+ make clean lazbuild
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin $pkgdir/usr/lib/lazarus
+ COMPRESSXZ=(xz -T 0 -c -z -)
+ cd $pkgname
+ cp -rf * $pkgdir/usr/lib/lazarus
+ cd $pkgdir/usr/bin
+ ln -f -s ../lib/lazarus/lazbuild lazbuild
+ cd $pkgdir/usr/lib/lazarus
+ rm -rf debian
+ rm -rf lazarus.app
+ rm -rf startlazarus.app
+ echo "Please be patient! We're on the way but compression takes a lot of time..."
+}
+sha256sums=('SKIP')