summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-05-28 22:49:44 -0600
committerAinola2018-05-28 22:49:44 -0600
commit6bb5f3af345c6e5c19cf7f4c6532950a493693cd (patch)
treebd2a2454e5c1e5057fb2c410a74d68b711e82c66
downloadaur-6bb5f3af345c6e5c19cf7f4c6532950a493693cd.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--lazy-ips.desktop9
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..282fdc9868c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lazy-ips
+ pkgdesc = ips patcher for Linux
+ pkgver = r2.9048f9f
+ pkgrel = 1
+ url = https://github.com/btimofeev/lazy_ips
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = pygtk
+ source = git+https://github.com/btimofeev/lazy_ips.git
+ source = lazy-ips.desktop
+ sha256sums = SKIP
+ sha256sums = 37d16380346b6270a90fc4903ee090bfaa5f3295d72e47c38f9bc3cd38104909
+
+pkgname = lazy-ips
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3865c18b0fee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ainola
+
+pkgname=lazy-ips
+pkgver=r2.9048f9f
+pkgrel=1
+pkgdesc="ips patcher for Linux"
+arch=('any')
+url="https://github.com/btimofeev/lazy_ips"
+license=('GPL3')
+depends=('python2' 'pygtk')
+source=(
+ "git+https://github.com/btimofeev/lazy_ips.git"
+ 'lazy-ips.desktop'
+)
+sha256sums=('SKIP'
+ '37d16380346b6270a90fc4903ee090bfaa5f3295d72e47c38f9bc3cd38104909')
+
+pkgver() {
+ cd "$srcdir/lazy_ips"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "$srcdir/lazy_ips/lazy_ips.py" "$pkgdir/usr/bin/lazy_ips"
+ ln -s /usr/bin/lazy_ips "$pkgdir/usr/bin/lazy-ips"
+ install -Dm644 "$srcdir/lazy-ips.desktop" "$pkgdir/usr/share/applications/lazy-ips.desktop"
+}
diff --git a/lazy-ips.desktop b/lazy-ips.desktop
new file mode 100644
index 000000000000..43e6ed00d4b8
--- /dev/null
+++ b/lazy-ips.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Exec=/usr/bin/lazy_ips
+Name=Lazy IPS
+NoDisplay=false
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Games;
+GenericName=ROM IPS Patching Utility