summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorf4402020-12-22 22:30:58 +0900
committerf4402020-12-22 22:30:58 +0900
commit8af5d909c3b6d162c8171dbe0c0d8b8f5db00da7 (patch)
treec38ff13ae3477ff2d2420166b5ad8f2588e5334a
downloadaur-8af5d909c3b6d162c8171dbe0c0d8b8f5db00da7.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb3b051e8370
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = lazygit-bin
+ pkgdesc = simple terminal UI for git commands. Pre-compiled.
+ pkgver = 0.23.7
+ pkgrel = 1
+ url = https://github.com/jesseduffield/lazygit
+ arch = x86_64
+ license = MIT
+ provides = lazygit
+ conflicts = lazygit
+ source = lazygit-0.23.7_linux_amd64.zip::https://github.com/jesseduffield/lazygit/releases/download/v0.23.7/lazygit_0.23.7_Linux_x86_64.tar.gz
+ sha256sums = 84528f6c2d29e15d237bddd152d0cd59ddba0119f99413d37445ec39eedfe467
+
+pkgname = lazygit-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ceca97cc7c99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: f440 <freq440@gmail.com>
+
+pkgname=lazygit-bin
+pkgver=0.23.7
+pkgrel=1
+pkgdesc="simple terminal UI for git commands. Pre-compiled."
+arch=('x86_64')
+url="https://github.com/jesseduffield/lazygit"
+license=('MIT')
+depends=()
+provides=('lazygit')
+conflicts=('lazygit')
+
+source=("${pkgname/-bin/}-${pkgver}_linux_amd64.zip::https://github.com/jesseduffield/lazygit/releases/download/v${pkgver}/${pkgname/-bin/}_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums=('84528f6c2d29e15d237bddd152d0cd59ddba0119f99413d37445ec39eedfe467')
+
+package() {
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/lazygit/LICENSE"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/licenses/lazygit/README.md"
+ install -Dm755 "lazygit" "${pkgdir}/usr/bin/lazygit"
+}