summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfuero2018-08-10 13:54:28 +0200
committerfuero2018-08-10 13:54:28 +0200
commit43ac559180809d1b6236823c695bb120c4c47178 (patch)
tree829be2eece84dfd3e6c0b6521ed1f8a543cbe586
parent3f5469250c72c248e0ef980fe41d29b0d198a165 (diff)
downloadaur-43ac559180809d1b6236823c695bb120c4c47178.tar.gz
Now points to master branch, minor fixes
- Uses suggestions from https://github.com/jesseduffield/lazygit/issues/74 to bake in the git revision and build time. - Adds missing documentation files. - Symlinks the source rather than copying to satisfy go. - Point to master branch instead of locking to a commit.
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD21
2 files changed, 15 insertions, 7 deletions
diff --git a/.gitignore b/.gitignore
index e0a867ca5333..77988327b576 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*.pkg.tar.xz
*.tar.gz
+*.log
/pkg/
/lazygit/
/src/
diff --git a/PKGBUILD b/PKGBUILD
index 1a4f5f2da6f1..75c0d4761669 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer : fuero <fuerob@gmail.com>
pkgname='lazygit-git'
pkgdesc='A simple terminal UI for git commands'
+pkgver=r320.a8c6f31
pkgrel=1
-pkgver=r180.acae855
_repo_prefix='github.com/jesseduffield'
_repo_name="${pkgname/-git}"
url="https://${_repo_prefix}/${_repo_name}"
@@ -10,7 +10,7 @@ license=('MIT')
arch=('x86_64')
makedepends=('go-pie' 'git')
depends=('glibc')
-_commit='acae855ace3973468fe697c9c4437bd0b76a705d'
+_commit='master'
source=("git+https://${_repo_prefix}/${_repo_name}#commit=${_commit}")
sha512sums=('SKIP')
@@ -23,20 +23,27 @@ prepare () {
export GOPATH="${srcdir}"
export PATH="$PATH:$GOPATH/bin"
mkdir -p "src/${_repo_prefix}"
- cp -R "${_repo_name}" "src/${_repo_prefix}"
+ ln -snf "$(pwd)/${_repo_name}" "src/${_repo_prefix}/${_repo_name}"
+}
+
+clean() {
+ # Clean up symlink
+ rm -f "src/${_repo_prefix}/${_repo_name}"
+ rm -f ${_repo_name}.bin
}
build () {
cd "src/${_repo_prefix}/${_repo_name}"
- go build -o ${_repo_name}
+ go build -i -v -ldflags "-w -s -X main.Rev=${pkgver##*.} -X main.builddate=`date -u +%Y%m%d.%H%M%S`" -o ${_repo_name}.bin
}
package () {
cd "src/${_repo_prefix}/${_repo_name}"
- install -Dm755 ${_repo_name} "${pkgdir}/usr/bin/${_repo_name}"
+ install -Dm755 ${_repo_name}.bin "${pkgdir}/usr/bin/${_repo_name}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- for file in README.md ; do
- install -Dm644 "${file}" "${pkgdir}/usr/share/doc/${pkgname}/${file}"
+ for file in *.md docs/*.md
+ do
+ install -Dm644 "${file}" "${pkgdir}/usr/share/doc/${pkgname}/$(basename $file)"
done
}