summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJace Bennest2020-02-26 23:44:20 -0800
committerJace Bennest2020-02-26 23:44:20 -0800
commitbe25133e7800a020d6651a3238c02cc79f0dbc52 (patch)
tree4d52809798c8062a3702b0d9cbf2214f4a4b6b9e
downloadaur-lazystream-git.tar.gz
first release
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64ebe6112a05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lazystream-git
+ pkgdesc = Easily get LazyMan stream links, output directly or to m3u / xmltv formats. Streams can also be recorded or casted.
+ pkgver = 1.9.4.20200226
+ pkgrel = 1
+ url = https://github.com/tarkah/lazystream
+ arch = any
+ license = GPL2
+ depends = rust
+ depends = streamlink
+ optdepends = vlc
+ source = git+https://github.com/tarkah/lazystream.git
+ md5sums = SKIP
+
+pkgname = lazystream-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ce775e6a5ed0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+lazystream
+*pkg.tar.xz \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5402803d75e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jace Bennest <jacebennest87 at gmail dot com>
+# Contributor: tarkah <github dot com slash tarkah>
+# Contributor: StevensNJD4 <github dot com slash StevensNJD4>
+
+pkgname=lazystream-git
+pkgver=1.9.4.20200226
+pkgrel=1
+pkgdesc="Easily get LazyMan stream links, output directly or to m3u / xmltv formats. Streams can also be recorded or casted."
+arch=('any')
+url='https://github.com/tarkah/lazystream'
+license=('GPL2')
+depends=('rust' 'streamlink')
+optdepends=('vlc')
+
+source=("git+$url.git")
+
+build() {
+ cd "$srcdir/lazystream"
+ rm -rf target
+ cargo build --release
+}
+
+package() {
+ install -Dm755 lazystream/target/release/lazystream "$pkgdir/usr/bin/lazystream"
+}
+
+md5sums=('SKIP')