summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjason2015-07-10 10:51:45 +1200
committerjason2015-07-10 10:51:45 +1200
commit9e5f3dc8d037b4b3136917b3cd4f9863f16b9cb0 (patch)
tree0f4d32d36b104f0d13846e728a7a6a71aa514b6f
downloadaur-9e5f3dc8d037b4b3136917b3cd4f9863f16b9cb0.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..993d3ab77e42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lbdb
+ pkgdesc = The little brother's database for the mutt mail reader
+ pkgver = 0.39
+ pkgrel = 1
+ url = http://www.spinnaker.de/lbdb/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = awk
+ depends = glibc
+ depends = perl
+ optdepends = libvformat: for reading vcard files (needed at compile time)
+ optdepends = inetutils: provides the hostname binary
+ optdepends = netkit-bsd-finger: finger module
+ backup = etc/lbdb.rc
+ backup = etc/lbdb_ldap.rc
+ source = http://www.spinnaker.de/debian/lbdb_0.39.tar.gz
+ md5sums = b4739fd4e331e41da8a634c24c98a2c8
+
+pkgname = lbdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55c77d026f8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: jason ryan <jasonwryan@gmail.com>
+# Contributor: Andreas Wagner <Andreas dot Wagner at em dot uni-frankfurt dot de>
+
+pkgname=lbdb
+pkgver=0.39
+pkgrel=1
+pkgdesc="The little brother's database for the mutt mail reader"
+arch=('i686' 'x86_64')
+url="http://www.spinnaker.de/lbdb/"
+license=('GPL')
+depends=('awk' 'glibc' 'perl')
+optdepends=('libvformat: for reading vcard files (needed at compile time)' \
+ 'inetutils: provides the hostname binary' \
+ 'netkit-bsd-finger: finger module' )
+backup=('etc/lbdb.rc' 'etc/lbdb_ldap.rc')
+source=(http://www.spinnaker.de/debian/${pkgname}_${pkgver}.tar.gz)
+md5sums=('b4739fd4e331e41da8a634c24c98a2c8')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make install_prefix=$pkgdir install
+}
+