summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormissing2022-06-29 19:34:30 +0100
committermissing2022-06-29 19:34:30 +0100
commitee8004b5b1999425661c5e3fa8af89facf277000 (patch)
treead090795aa23aefa19750f37b0330e4b745524a1
parent4804e42542acd84b91253d0efbc073f02745ed12 (diff)
downloadaur-ee8004b5b1999425661c5e3fa8af89facf277000.tar.gz
Allow skipping patches without error
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 395c18fe6f4f..d3fb1790f0f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,18 +31,18 @@ build() {
python -m venv lbry-venv
source lbry-venv/bin/activate
- patch --strip=0 --input=lbry-rocksdb.patch
+ patch --strip=0 --input=lbry-rocksdb.patch || true
cd lbry-rocksdb
make
pip install -e .
cd ../
- patch --strip=0 --input="lbry-sdk-${pkgver}.patch"
+ patch --strip=0 --input="lbry-sdk-${pkgver}.patch" || true
cd "lbry-sdk-${pkgver}"
make install
cd ..
- patch --strip=0 --input=lbry-venv.patch
+ patch --strip=0 --input=lbry-venv.patch || true
mkdir build
cd build