summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardenapple2020-08-26 00:22:06 +0300
committergardenapple2020-08-26 00:22:06 +0300
commit877da2086141d57393f60a21e133beca1bdb32aa (patch)
tree6f1f5006f97e8de0278511800dfb1276a2901ab5
downloadaur-877da2086141d57393f60a21e133beca1bdb32aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d5c92808e6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lbrynet-bin
+ pkgdesc = Implementation of the LBRY Network protocols, without the desktop app
+ pkgver = 0.81.0
+ pkgrel = 1
+ url = https://lbry.tech/
+ arch = x86_64
+ license = MIT
+ provides = lbrynet
+ conflicts = lbry-app-bin>=0.47.1
+ source = https://github.com/lbryio/lbry-sdk/releases/download/v0.81.0/lbrynet-linux.zip
+ source = lbrynet-LICENSE::https://raw.githubusercontent.com/lbryio/lbry-sdk/master/LICENSE
+ b2sums = bc14b11c09b0502490b5a4d17bcdb597b5603541f402458a30ca7df3e594c60e871fb855ce583421b22cc468124bb281c20803e9784f0b0e0ad6fccbbf358d47
+ b2sums = c17e30091ae9d3f6ad3f5a70c80ff686bdcbfc41b9b603d5693c34a006aba635968ebc67aa5ddeb607053b098ad8d3d3a03b790249ab58b9cbb6f66ba6cf5693
+
+pkgname = lbrynet-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..85d9f964e308
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.pkg.tar.*
+lbrynet-linux.zip
+lbrynet-LICENSE
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50dbad5a8646
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Yurii <yu hrysh at posteo dot net>
+
+pkgname=lbrynet-bin
+pkgver=0.81.0
+pkgrel=1
+pkgdesc='Implementation of the LBRY Network protocols, without the desktop app'
+arch=('x86_64')
+url='https://lbry.tech/'
+license=('MIT')
+conflicts=('lbry-app-bin>=0.47.1')
+provides=('lbrynet')
+source=("https://github.com/lbryio/lbry-sdk/releases/download/v$pkgver/lbrynet-linux.zip"
+ 'lbrynet-LICENSE::https://raw.githubusercontent.com/lbryio/lbry-sdk/master/LICENSE')
+
+package() {
+ install -Dm755 "${srcdir}/lbrynet" -t "${pkgdir}/usr/bin/"
+ install -Dm644 "${srcdir}/lbrynet-LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}
+b2sums=('bc14b11c09b0502490b5a4d17bcdb597b5603541f402458a30ca7df3e594c60e871fb855ce583421b22cc468124bb281c20803e9784f0b0e0ad6fccbbf358d47'
+ 'c17e30091ae9d3f6ad3f5a70c80ff686bdcbfc41b9b603d5693c34a006aba635968ebc67aa5ddeb607053b098ad8d3d3a03b790249ab58b9cbb6f66ba6cf5693')