summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgardenapple2020-08-25 23:32:07 +0300
committergardenapple2020-08-25 23:53:36 +0300
commit39cc181e3b109bfbb24c5e47675d57e629abfab5 (patch)
treedf2cfd9bfa1efb0a62cc1b9dfeee894c884a9352
downloadaur-39cc181e3b109bfbb24c5e47675d57e629abfab5.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..590078bb916f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = lbt
+ pkgdesc = Command-line tools for interacting with the LBRY network
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/gardenappl/lbt
+ arch = any
+ license = GPL3
+ depends = jq
+ depends = curl
+ optdepends = lbry-app-bin>=0.47.1: LBRY application
+ source = https://gitlab.com/gardenappl/lbt/-/archive/v1.0/lbt-v1.0.tar.gz
+ b2sums = 0a86ec1f5c33b0f59729161b7fb0830255a14a1f7cd9bf4be3783f3a4cdbf4a93feec2ea26b7afa877d77514db3a0f8f385c1e3370c3dac259f96c480adc40b3
+
+pkgname = lbt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3474ffd2f84f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.*
+lbt-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46aaceefbb23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Yurii <yu hrysh at posteo dot net>
+
+pkgname=lbt
+_author=gardenappl
+pkgver=1.0
+pkgrel=1
+pkgdesc='Command-line tools for interacting with the LBRY network'
+arch=('any')
+url='https://gitlab.com/gardenappl/lbt'
+license=('GPL3')
+depends=('jq' 'curl')
+optdepends=("lbry-app-bin>=0.47.1: LBRY application")
+source=("https://gitlab.com/$_author/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+
+package() {
+ # The gettext localization is barely functional, so not bothering to install it
+
+ install -Dm755 "${srcdir}/$pkgname-v$pkgver"/lbt -t "${pkgdir}/usr/bin/"
+ install -Dm644 "${srcdir}/$pkgname-v$pkgver"/lbt-open.desktop -t "${pkgdir}/usr/share/applications/"
+}
+b2sums=('0a86ec1f5c33b0f59729161b7fb0830255a14a1f7cd9bf4be3783f3a4cdbf4a93feec2ea26b7afa877d77514db3a0f8f385c1e3370c3dac259f96c480adc40b3')