summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Marquesi Lerner2022-03-05 09:51:29 -0300
committerIvan Marquesi Lerner2022-03-05 09:51:29 -0300
commit36c63c4f74ce292a696d771904a7810ad3e16d39 (patch)
tree251b99067d186284fb628479a1e4d93d327bf619
parent31ce0ed8c0f9e138ce128c5bbf7e364110a7e604 (diff)
downloadaur-36c63c4f74ce292a696d771904a7810ad3e16d39.tar.gz
Added new weights file and clang dependency
-rwxr-xr-x.SRCINFO7
-rwxr-xr-x.gitignore2
-rwxr-xr-xPKGBUILD10
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 014db3693080..2b6687f71798 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lc0
pkgdesc = UCI-compliant chess engine designed to play chess via neural network, specifically those of the LeelaChessZero project.
pkgver = 0.28.2
- pkgrel = 1
+ pkgrel = 2
url = https://lczero.org/
install = lc0.install
arch = x86_64
@@ -14,15 +14,16 @@ pkgbase = lc0
depends = ocl-icd
depends = zlib
depends = opencl-driver
+ depends = clang
optdepends = cudnn: Neural network library for use with nvidia GPUs
noextract = $_weights
source = lc0
source = lc0-0.28.2.tar.gz::https://github.com/LeelaChessZero/lc0/archive/v0.28.2.tar.gz
source = lczero-common-master.tar.gz::https://github.com/LeelaChessZero/lczero-common/archive/master.tar.gz
- source = weights_sergio-v_256x20-T40-1541.pb.gz::https://www.comp.nus.edu.sg/~sergio-v/t40/256x20/256x20-t40-1541.pb.gz
+ source = weights_hanse-69722-vf2.gz::https://storage.lczero.org/files/networks-contrib/hanse-69722-vf2.gz
sha256sums = 10f0fc4126bd2c9303bd2474c0d9ef488ceb7690cbca7c7d8ace61679ae97b49
sha256sums = 5fe8a39c82a9be2b185b57d093417ed290fc36596cb23bc731e05a57fa70f65c
sha256sums = fa3671e89e647c7da931b1934c66b4de129681d9b0a8df22ce932596357cda1a
- sha256sums = ddfaf13cb77f14e59edca75f1ac4c7a0d0a62659034f92bea48d0c66d35b79d5
+ sha256sums = a519393981e68112628f739e261303987477058027f73c584c1e89302ec55b87
pkgname = lc0
diff --git a/.gitignore b/.gitignore
index e4ca3bc69102..ede42f9b9980 100755
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
lc0-*.tar.gz
lc0-*.pkg.tar.zst
lczero-common-master.tar.gz
-weights_sergio-v_256x20-T40-1541.pb.gz
+weights_hanse-69722-vf2.gz
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index 4f913877c6e2..7c1bfde5f7f7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lc0
pkgver=0.28.2
-pkgrel=1
+pkgrel=2
pkgdesc="UCI-compliant chess engine designed to play chess via neural network, \
specifically those of the LeelaChessZero project."
arch=('x86_64')
@@ -10,21 +10,21 @@ arch=('x86_64')
url="https://lczero.org/"
license=('GPL3')
-depends=('ocl-icd' 'zlib' 'opencl-driver')
+depends=('ocl-icd' 'zlib' 'opencl-driver' 'clang')
makedepends=('meson' 'eigen' 'opencl-headers' 'openblas-cblas-git')
checkdepends=('gtest')
optdepends=("cudnn: Neural network library for use with nvidia GPUs")
-_weights="weights_sergio-v_256x20-T40-1541.pb.gz"
+_weights="weights_hanse-69722-vf2.gz"
install=lc0.install
source=("$pkgname"
"$pkgname-$pkgver.tar.gz::https://github.com/LeelaChessZero/$pkgname/archive/v$pkgver.tar.gz"
"lczero-common-master.tar.gz::https://github.com/LeelaChessZero/lczero-common/archive/master.tar.gz"
- "$_weights::https://www.comp.nus.edu.sg/~sergio-v/t40/256x20/256x20-t40-1541.pb.gz")
+ "$_weights::https://storage.lczero.org/files/networks-contrib/hanse-69722-vf2.gz")
sha256sums=('10f0fc4126bd2c9303bd2474c0d9ef488ceb7690cbca7c7d8ace61679ae97b49'
'5fe8a39c82a9be2b185b57d093417ed290fc36596cb23bc731e05a57fa70f65c'
'fa3671e89e647c7da931b1934c66b4de129681d9b0a8df22ce932596357cda1a'
- 'ddfaf13cb77f14e59edca75f1ac4c7a0d0a62659034f92bea48d0c66d35b79d5')
+ 'a519393981e68112628f739e261303987477058027f73c584c1e89302ec55b87')
noextract=('$_weights')
prepare() {