summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Marquesi Lerner2019-08-04 06:20:58 -0300
committerIvan Marquesi Lerner2019-08-04 06:20:58 -0300
commitc93ccdc1223123ea49408c7e38dd4a42ea73a6cf (patch)
tree3de40a96317435ea1dfdcf701fb828764e78edbf
parent389da3aba53c9c3b964690ed8289ca8d110c20e4 (diff)
downloadaur-c93ccdc1223123ea49408c7e38dd4a42ea73a6cf.tar.gz
Added dependencies and minor fixes/changes.
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 466113869a26..32e2e12e35d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lc0
pkgver=0.21.4
-pkgrel=1
+pkgrel=2
_run="run1"
_nnid=42850
pkgdesc="UCI-compliant chess engine designed to play chess via neural network, \
@@ -12,19 +12,23 @@ arch=('x86_64')
url="https://lczero.org/"
license=('GPL3')
-depends=('protobuf' 'ocl-icd')
+depends=('protobuf' 'ocl-icd' 'opencl-driver')
makedepends=('meson' 'zlib')
checkdepends=('gtest')
optdepends=("nvidia: Necessary for running on nvidia GPUs"
- "cudnn: xNeural network library for use with nvidia GPUs"
+ "cudnn: Neural network library for use with nvidia GPUs"
+ "openblas: Library for running on CPUs"
"intel-compute-runtime: Intel OpenCL runtime for \
running on intel CPUs"
- "amdapp-sdk: AMD OpenCL runtime for running on amd CPUs"
- "openblas: Library for running on CPUs"
- "opencl-mesa: Free runtime for use with AMDGPU driver stack"
+ "amdapp-sdk: AMD OpenCL runtime for running on AMD CPUs"
+ "xf86-video-amdgpu: AMDGPU driver stack"
+ "xf86-video-ati: ATI driver stack"
+ "opencl-mesa: Open AMD runtime for use with AMDGPU \
+ and ATI driver stacks"
"opencl-amd: AMD proprietary userspace driver \
for AMDGPU driver stack"
"rocm-opencl-runtime: AMD runtime for ROCm GPU driver stack"
+ "amdgpu-pro-libgl: AMDGPU PRO driver stack"
"opencl-amdgpu-pro-orca: AMD proprietary runtime for legacy \
GPUs on the AMDGPU PRO driver stack"
"opencl-amdgpu-pro-pal: AMD proprietary runtime for the \