summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Marquesi Lerner2020-09-04 17:38:19 -0300
committerIvan Marquesi Lerner2020-09-04 17:38:19 -0300
commitcd84d3b3bd1e515b1c54a4dd4e8d3e7025dcf722 (patch)
tree78b3ae497b454b23ae0ea2765c9d36aec8a93600
parent4a4c028d67d09628ccee217b83afd84dbe3fe61d (diff)
downloadaur-cd84d3b3bd1e515b1c54a4dd4e8d3e7025dcf722.tar.gz
Update to 0.26.2 and updated weights file to the recommended one for a general use case.
-rwxr-xr-x.SRCINFO12
-rwxr-xr-x.gitignore5
-rwxr-xr-xPKGBUILD15
3 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 845f186ce3cf..9834cd2abc71 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lc0
pkgdesc = UCI-compliant chess engine designed to play chess via neural network, specifically those of the LeelaChessZero project.
- pkgver = 0.26.1
+ pkgver = 0.26.2
pkgrel = 1
url = https://lczero.org/
install = lc0.install
@@ -14,15 +14,15 @@ pkgbase = lc0
depends = zlib
depends = opencl-driver
optdepends = cudnn: Neural network library for use with nvidia GPUs
- noextract = weights_${_run}_${_nnid}.pb.gz
+ noextract = $_weights
source = lc0
- source = lc0-0.26.1.tar.gz::https://github.com/LeelaChessZero/lc0/archive/v0.26.1.tar.gz
+ source = lc0-0.26.2.tar.gz::https://github.com/LeelaChessZero/lc0/archive/v0.26.2.tar.gz
source = lczero-common-master.tar.gz::https://github.com/LeelaChessZero/lczero-common/archive/master.tar.gz
- source = weights_run1_42850.pb.gz::http://data.lczero.org/files/networks/00af53b081e80147172e6f281c01daf5ca19ada173321438914c730370aa4267
+ source = weights_sergio-v_256x20-T40-1541.pb.gz::https://www.comp.nus.edu.sg/~sergio-v/t40/256x20/256x20-t40-1541.pb.gz
md5sums = 8ef8809da2c627dd2472859b157bb408
- md5sums = 89cb56d60740c622db63f4daeef4b70f
+ md5sums = 4d2b78aa66b3f99d4cf8e8de0e9e6d6c
md5sums = e8eda64758da58c6a82126b9dc7c69ff
- md5sums = e7c9e1abec8d859ffdbc89e18340c254
+ md5sums = SKIP
pkgname = lc0
diff --git a/.gitignore b/.gitignore
index 6bee85a1194c..e4ca3bc69102 100755
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
-lc0-0.23.3.tar.gz
+lc0-*.tar.gz
+lc0-*.pkg.tar.zst
lczero-common-master.tar.gz
-weights_run1_42850.pb.gz
+weights_sergio-v_256x20-T40-1541.pb.gz
pkg
src
diff --git a/PKGBUILD b/PKGBUILD
index d5cab4275f1f..ee7c2886dd5c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,8 @@
# Maintainer: Ivan Marquesi Lerner <ivanmlerner@protonmail.com>
pkgname=lc0
-pkgver=0.26.1
+pkgver=0.26.2
pkgrel=1
-_run="run1"
-_nnid=42850
pkgdesc="UCI-compliant chess engine designed to play chess via neural network, \
specifically those of the LeelaChessZero project."
arch=('x86_64')
@@ -17,16 +15,17 @@ makedepends=('meson' 'eigen' 'opencl-headers')
checkdepends=('gtest')
optdepends=("cudnn: Neural network library for use with nvidia GPUs")
+_weights="weights_sergio-v_256x20-T40-1541.pb.gz"
install=lc0.install
source=("$pkgname"
"$pkgname-$pkgver.tar.gz::https://github.com/LeelaChessZero/$pkgname/archive/v$pkgver.tar.gz"
"lczero-common-master.tar.gz::https://github.com/LeelaChessZero/lczero-common/archive/master.tar.gz"
- "weights_${_run}_${_nnid}.pb.gz::http://data.lczero.org/files/networks/00af53b081e80147172e6f281c01daf5ca19ada173321438914c730370aa4267")
+ "$_weights::https://www.comp.nus.edu.sg/~sergio-v/t40/256x20/256x20-t40-1541.pb.gz")
md5sums=('8ef8809da2c627dd2472859b157bb408'
- '89cb56d60740c622db63f4daeef4b70f'
+ '4d2b78aa66b3f99d4cf8e8de0e9e6d6c'
'e8eda64758da58c6a82126b9dc7c69ff'
- 'e7c9e1abec8d859ffdbc89e18340c254')
-noextract=('weights_${_run}_${_nnid}.pb.gz')
+ 'SKIP')
+noextract=('$_weights')
prepare() {
cp -PRu "$srcdir/lczero-common-master/proto" "$srcdir/$pkgname-$pkgver/libs/lczero-common/"
@@ -56,5 +55,5 @@ check() {
package() {
install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm755 "$srcdir/$pkgname-$pkgver/build/release/$pkgname" "$pkgdir/usr/lib/$pkgname/$pkgname"
- install -Dm644 "$srcdir/weights_${_run}_${_nnid}.pb.gz" "$pkgdir/usr/lib/$pkgname/weights_${_run}_${_nnid}.pb.gz"
+ install -Dm644 "$srcdir/${_weights}" "$pkgdir/usr/lib/$pkgname/${_weights}"
}