summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMisaka135142024-04-18 15:48:09 +0800
committerMisaka135142024-04-18 15:48:09 +0800
commitdeb4053a5a67c1bd089d357cbca7806f2a027cbf (patch)
tree027a6dc8c7ca6f4d622ceec2c81f67a2395f5878
parent29d5f3ee931dc6ba330f3b8b77c5d35ec016e229 (diff)
parent94f5ce63e7e9f99c409c41d3a76a5d4a90689d12 (diff)
downloadaur-deb4053a5a67c1bd089d357cbca7806f2a027cbf.tar.gz
upgpkg: lceda-pro 2.1.57-1
upstream release Merge subtree 'lceda-pro'
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 27 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 279aa0add598..138ee28eeea9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,28 +5,19 @@ pkgbase = lceda-pro
url = https://pro.lceda.cn/
install = lceda-pro.install
arch = x86_64
- arch = aarch64
- arch = loong64
license = LicenseRef-LCEDA-Proprietary
- depends = electron
- depends = gtk3
- depends = nss
+ makedepends = aria2
depends = alsa-lib
- depends = libpulse
depends = bash
- depends = hicolor-icon-theme
- depends = gcc-libs
depends = coreutils
+ depends = electron
+ depends = gcc-libs
depends = glibc
- source = LICENSE-2.1.57.html::https://lceda.cn/page/legal
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libpulse
+ depends = nss
source = lceda-pro.install
- sha256sums = SKIP
sha256sums = afba3c6712227a37c08783b3cc1a97ae71e90dc2f575409213d2773372220697
- source_x86_64 = lceda-pro-x86_64-2.1.57.zip::https://image.lceda.cn/files/lceda-pro-linux-x64-2.1.57.zip
- sha256sums_x86_64 = 5cd52b10328c5e4d3f21bfcb716ac9267427098e345fe31130065a450fe1632a
- source_aarch64 = lceda-pro-aarch64-2.1.57.zip::https://image.lceda.cn/files/lceda-pro-linux-arm64-2.1.57.zip
- sha256sums_aarch64 = c36e9bb8cf317871b5a49808455c1b86cf335c346fd06542c278a53c75a7aad1
- source_loong64 = lceda-pro-loong64-2.1.57.zip::https://image.lceda.cn/files/lceda-pro-linux-loong64-2.1.57.zip
- sha256sums_loong64 = 72641ea129d0b22ffdf872fe40c986edd7b6c875ed7aabbeadc9dfa5966b4413
pkgname = lceda-pro
diff --git a/PKGBUILD b/PKGBUILD
index e4be93de193c..14cbda27379e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,33 @@
# Maintainer: taotieren <admin@taotieren.com>
# Co-Maintainer: Misaka13514 <Misaka13514 at gmail dot com>
-pkgbase=lceda-pro
pkgname=lceda-pro
pkgver=2.1.57
pkgrel=1
pkgdesc="免费、专业、强大的国产PCB设计工具"
-arch=('x86_64' 'aarch64' 'loong64')
+arch=(x86_64)
url="https://pro.lceda.cn/"
-license=('LicenseRef-LCEDA-Proprietary')
-depends=(electron
- gtk3
- nss
- alsa-lib
- libpulse
+license=(LicenseRef-LCEDA-Proprietary)
+depends=(alsa-lib
bash
- hicolor-icon-theme
- gcc-libs
coreutils
- glibc)
+ electron
+ gcc-libs
+ glibc
+ gtk3
+ hicolor-icon-theme
+ libpulse
+ nss)
+makedepends=(aria2)
install=${pkgname}.install
-source=("LICENSE-$pkgver.html::https://lceda.cn/page/legal"
- "${pkgname}.install")
-source_x86_64=("${pkgname}-x86_64-${pkgver}.zip::https://image.lceda.cn/files/lceda-pro-linux-x64-${pkgver}.zip")
-source_aarch64=("${pkgname}-aarch64-${pkgver}.zip::https://image.lceda.cn/files/lceda-pro-linux-arm64-${pkgver}.zip")
-source_loong64=("${pkgname}-loong64-${pkgver}.zip::https://image.lceda.cn/files/lceda-pro-linux-loong64-${pkgver}.zip")
-sha256sums=('SKIP'
- 'afba3c6712227a37c08783b3cc1a97ae71e90dc2f575409213d2773372220697')
-sha256sums_x86_64=('5cd52b10328c5e4d3f21bfcb716ac9267427098e345fe31130065a450fe1632a')
-sha256sums_aarch64=('c36e9bb8cf317871b5a49808455c1b86cf335c346fd06542c278a53c75a7aad1')
-sha256sums_loong64=('72641ea129d0b22ffdf872fe40c986edd7b6c875ed7aabbeadc9dfa5966b4413')
+source=("${pkgname}.install")
+sha256sums=('afba3c6712227a37c08783b3cc1a97ae71e90dc2f575409213d2773372220697')
+
+prepare() {
+ aria2c --max-concurrent-downloads=10 --max-connection-per-server=10 --split=10 https://lceda.cn/page/legal --out=LICENSE
+ aria2c --max-concurrent-downloads=10 --max-connection-per-server=10 --split=10 https://image.lceda.cn/files/${pkgname}-linux-x64-${pkgver}.zip
+ bsdtar --extract --file ${pkgname}-linux-x64-${pkgver}.zip --directory .
+}
package() {
# electron file
@@ -63,5 +61,5 @@ package() {
exec electron /usr/lib/lceda-pro/resources/app/ "\$@"
EOF
# LICENSE
- install -Dm0644 ${srcdir}/LICENSE-$pkgver.html ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html
+ install -Dm0644 ${srcdir}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}