summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2015-07-05 14:37:31 +0200
committerLucki2015-07-05 14:37:31 +0200
commit5fdd34a638b135ccb0637052a61e63c130981d19 (patch)
treea7a4d0caf2373ba8af720e903166681292ec3f33
downloadaur-5fdd34a638b135ccb0637052a61e63c130981d19.tar.gz
Initial import
-rw-r--r--.CHANGELOG67
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD64
3 files changed, 151 insertions, 0 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
new file mode 100644
index 000000000000..da318bcf000c
--- /dev/null
+++ b/.CHANGELOG
@@ -0,0 +1,67 @@
+* commit 75b2b31eedb89aeeef46f70215a9ba761237228f
+|\ Merge: 60bb38a c472961
+| | Author: Justin J. Meza <justin.meza@gmail.com>
+| | Date: Sun May 10 10:01:54 2015 -0700
+| |
+| | Merge pull request #25 from Quiri/master
+| |
+| | typo make docs
+| |
+| * commit c47296167922ea6cb8a85895fde689867d5cee7a
+|/ Author: kirill Mint <pomogajko@gmail.com>
+| Date: Sat May 2 21:56:38 2015 +0200
+|
+| typo make docs
+|
+* commit 60bb38a1f01bbcb2b44f3f454da65616ee489061
+| Author: Justin Meza <justin.meza@gmail.com>
+| Date: Sun Apr 12 16:29:59 2015 -0700
+|
+| adding Travis CI configuration file
+|
+* commit 7200aa9308bd446187327d54d19448a29b860a9c
+| Author: Justin Meza <justin.meza@gmail.com>
+| Date: Sun Apr 12 16:28:56 2015 -0700
+|
+| adding unhandled string detection error type
+|
+* commit 30301eb2a99a31d6bcbf305a703e6f04294bbe13
+|\ Merge: e017dc6 8c66da0
+| | Author: Justin Meza <justin.meza@gmail.com>
+| | Date: Sun Apr 12 16:22:59 2015 -0700
+| |
+| | Merge branch 'technion-versioncrash'
+| |
+| * commit 8c66da06673d4017e718d3db15247361a7930e80
+|/ Author: Technion <technion@lolware.net>
+| Date: Sun Apr 12 12:00:38 2015 +0000
+|
+| Defensive strategy that prevents a range of possible null pointer errors from causing crashes
+| This allows a graceful failure in the event of several identified invalid inputs.
+|
+* commit e017dc68c0a1fed8c5f3c0436d39882a1d95539a
+|\ Merge: 00fb94d 3fe31d0
+| | Author: Justin J. Meza <justin.meza@gmail.com>
+| | Date: Wed Nov 26 21:09:49 2014 -0800
+| |
+| | Merge pull request #22 from ord-nas/master
+| |
+| | Fixed problem with ME when using alternate method calling syntax
+| |
+| * commit 3fe31d043d57ca0c846b01f6669d224d185a18fd
+|/ Author: OrdNas <ade_ski@live.com>
+| Date: Wed Nov 26 17:58:53 2014 -0800
+|
+| Fixed problem with ME when using alternate method calling syntax
+|
+* commit 00fb94d9b3f223284de737ac40b85cff79124cea
+| Author: Justin Meza <justin.meza@gmail.com>
+| Date: Fri Oct 24 21:57:44 2014 -0700
+|
+| fix missing runtime array type check identified by LeartS
+|
+* commit 9420332149972a77f63c55d4ed44984cd5900f95
+| Author: Justin Meza <justin.meza@gmail.com>
+| Date: Thu Oct 23 22:57:10 2014 -0700
+|
+| fix induction variable update bug identified by LeartS
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e53f476882a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lci-git
+ pkgdesc = A simple and fast 1.2 lolcode interpreter written in C.
+ pkgver = 0.10.5.r10.g75b2b31
+ pkgrel = 1
+ url = http://lolcode.org/
+ changelog = .CHANGELOG
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = glibc
+ optdepends = gtksourceview3-lolcode: syntax highlight
+ provides = lci
+ conflicts = lci
+ source = lci-git::git://github.com/justinmeza/lci.git
+ sha512sums = SKIP
+
+pkgname = lci-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca6aad80f2ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Lucki <Lucki at holarse-linuxgaming dot de>
+# Contributor: Gerardo Marset <gammer1994@gmail.com>
+
+pkgname=lci-git
+_pkgurl=git://github.com/justinmeza/lci.git
+
+# Set this to true for the 1.4 draft (fileio, sockets, bukkits, …):
+_usedraft=false
+
+if test "$_usedraft" == "true"; then
+ # 1.4 draft:
+ _pkgurl=$_pkgurl#branch=future
+fi
+
+pkgver=0.10.5.r10.g75b2b31
+pkgrel=1
+pkgdesc="A simple and fast 1.2 lolcode interpreter written in C."
+arch=('i686' 'x86_64')
+url="http://lolcode.org/"
+license=('GPL3')
+changelog=.CHANGELOG
+depends=('glibc')
+makedepends=('git' 'cmake')
+optdepends=('gtksourceview3-lolcode: syntax highlight')
+provides=('lci')
+conflicts=('lci')
+source=(${pkgname}::${_pkgurl})
+sha512sums=('SKIP')
+
+pkgver()
+{
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare()
+{
+ # update .CHANGELOG
+ if [ ${_usedraft} == "false" ]; then
+ git -C ${srcdir}/${pkgname} log --graph -10 > ${startdir}/.CHANGELOG
+ else
+ git -C ${srcdir}/${pkgname} log --graph -10 --branches=future > ${startdir}/.CHANGELOG
+ fi
+}
+
+build()
+{
+ cd "$srcdir/$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+# make docs
+}
+
+#check()
+#{
+# cd "$srcdir/$pkgname"
+# ctest
+#}
+
+package()
+{
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+}