summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Zonca2016-05-05 08:50:31 -0400
committerEthan Zonca2016-05-05 08:50:31 -0400
commit9cb60db8ea8064a58b87bc08acd752af110cc064 (patch)
treeb1e637b2f2ee145256475fc828eccfd864fda79c
downloadaur-9cb60db8ea8064a58b87bc08acd752af110cc064.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faf8e41b5198
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu May 5 12:46:13 UTC 2016
+pkgbase = lcm
+ pkgdesc = Lightweight real-time networking library
+ pkgver = 1.3.1
+ pkgrel = 5
+ url = http://code.google.com/p/lcm/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = LGPL
+ depends = glib2
+ optdepends = java-environment: support for lcm-spy and other GUI tools
+ optdepends = ttf-dejavu: support for lcm-spy and other GUI tools
+ source = http://github.com/lcm-proj/lcm/releases/download/v1.3.1/lcm-1.3.1.zip
+ md5sums = 4355889a2367697a9458e83f6251f2b2
+
+pkgname = lcm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..080685bc4fa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Ethan Zonca <ethanzonca@ethanzonca.com>
+
+pkgname=lcm
+pkgver=1.3.1
+pkgrel=5
+pkgdesc="Lightweight real-time networking library"
+arch=('i686' 'x86_64' 'armv7h')
+url="http://code.google.com/p/lcm/"
+license=('LGPL')
+depends=('glib2')
+optdepends=(
+ 'java-environment: support for lcm-spy and other GUI tools'
+ 'ttf-dejavu: support for lcm-spy and other GUI tools'
+)
+makedepends=()
+source=(http://github.com/lcm-proj/lcm/releases/download/v${pkgver}/$pkgname-$pkgver.zip)
+
+md5sums=('61ea232993a750285686cd63f1cfcd3f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}