summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2015-07-07 14:36:12 +0200
committerLukas Fleischer2015-07-08 13:25:13 +0200
commit2270c337f9d9f18ca2563fd49465c1c5d877db6f (patch)
tree523bef6ef631ff8a663836ef6bccc5ccebb5aabd
downloadaur-2270c337f9d9f18ca2563fd49465c1c5d877db6f.tar.gz
Initial import
-rw-r--r--.SRCINFO29
-rw-r--r--Changelog24
-rw-r--r--PKGBUILD39
-rw-r--r--lcmc4
-rw-r--r--lcmc.desktop10
-rw-r--r--lcmc.install12
-rw-r--r--lcmc.pngbin0 -> 4844 bytes
7 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3b8e6998cc1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lcmc
+ pkgdesc = Linux Cluster Management Console
+ pkgver = 1.7.8
+ pkgrel = 1
+ url = http://lcmc.sourceforge.net/
+ install = lcmc.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = java-runtime-common
+ depends = libxtst
+ depends = bash
+ depends = hicolor-icon-theme
+ noextract = LCMC-1.7.8.jar
+ source = http://downloads.sourceforge.net/project/lcmc/LCMC-1.7.8.jar
+ source = lcmc
+ source = lcmc.png
+ source = lcmc.desktop
+ source = lcmc.install
+ source = Changelog
+ sha1sums = 17b9b404bfa5460e1b6c80b054f8d5efe9208b81
+ sha1sums = acff8d95b9c1b55940e359c3c4c796ac6f3fc0a9
+ sha1sums = 84f8ab9b450c9e51d828435f12e72cfc851af0cf
+ sha1sums = 583f30b90058efb742a9ecc8e7f33e5e98048341
+ sha1sums = e8b239a493dd5e1eb7e3dc5989bb03800e76a38d
+ sha1sums = SKIP
+
+pkgname = lcmc
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..3872ef7ac8f8
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,24 @@
+2015/04/25 - lcmc-1.7.8-1
+ * New 1.7.8 version of lcmc
+
+2015/03/30 - lcmc-1.7.7-1
+ * New 1.7.7 version of lcmc
+
+2015/01/07 - lcmc-1.7.6-1
+ * New 1.7.6 version of lcmc
+ * New project maintainer mrxx
+
+2013/07/08 - lcmc-1.5.6-1
+ * New 1.5.6 version of lcmc
+
+2013/01/03 - lcmc-1.4.5-1
+ * New 1.4.5 version of lcmc
+ * Exec java in lcmc shell script
+
+2012/02/27 - lcmc-1.4.1-1
+ * New 1.4.1 version of lcmc
+
+2012/02/27 - lcmc-1.3.0-1
+ * New 1.3.0 version of lcmc
+ * Added icon file
+ * Added desktop file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..489625547c7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
+# previous maintainer: Gwenn Gueguen <gwenn+aur@demisel.net>
+
+pkgname=lcmc
+pkgver=1.7.8
+pkgrel=1
+pkgdesc="Linux Cluster Management Console"
+arch=('i686' 'x86_64')
+url="http://lcmc.sourceforge.net/"
+license=('GPL')
+depends=('java-runtime-common' 'libxtst' 'bash' 'hicolor-icon-theme')
+source=("http://downloads.sourceforge.net/project/$pkgname/LCMC-$pkgver.jar"
+ 'lcmc'
+ 'lcmc.png'
+ 'lcmc.desktop'
+ 'lcmc.install'
+ 'Changelog')
+noextract=(LCMC-$pkgver.jar)
+install=lcmc.install
+
+sha1sums=('17b9b404bfa5460e1b6c80b054f8d5efe9208b81'
+ 'acff8d95b9c1b55940e359c3c4c796ac6f3fc0a9'
+ '84f8ab9b450c9e51d828435f12e72cfc851af0cf'
+ '583f30b90058efb742a9ecc8e7f33e5e98048341'
+ 'e8b239a493dd5e1eb7e3dc5989bb03800e76a38d'
+ 'SKIP')
+
+package() {
+ cd "$srcdir"
+ install -d $pkgdir/usr/bin
+ install -m 0755 -t $pkgdir/usr/bin lcmc
+ install -d $pkgdir/usr/lib/${pkgname}
+ install -t $pkgdir/usr/lib/${pkgname} LCMC-$pkgver.jar Changelog
+ mv $pkgdir/usr/lib/${pkgname}/LCMC-$pkgver.jar $pkgdir/usr/lib/${pkgname}/${pkgname^^*}.jar
+ install -d $pkgdir/usr/share/icons/hicolor/48x48/apps
+ install -t $pkgdir/usr/share/icons/hicolor/48x48/apps ${pkgname}.png
+ install -d $pkgdir/usr/share/applications
+ install -t $pkgdir/usr/share/applications ${pkgname}.desktop
+}
diff --git a/lcmc b/lcmc
new file mode 100644
index 000000000000..75851bc9cf16
--- /dev/null
+++ b/lcmc
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+exec java -jar /usr/lib/lcmc/LCMC.jar
+
diff --git a/lcmc.desktop b/lcmc.desktop
new file mode 100644
index 000000000000..566e08ce1fde
--- /dev/null
+++ b/lcmc.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=LCMC
+GenericName=Linux Cluster Management Console
+Exec=/usr/bin/lcmc
+Icon=/usr/share/icons/hicolor/48x48/apps/lcmc.png
+Terminal=false
+Type=Application
+Categories=Java;Network;
diff --git a/lcmc.install b/lcmc.install
new file mode 100644
index 000000000000..b81efc695f86
--- /dev/null
+++ b/lcmc.install
@@ -0,0 +1,12 @@
+post_install() {
+ [[ -x /usr/bin/update-desktop-database ]] && /usr/bin/update-desktop-database -q
+ [[ -x /usr/bin/gtk-update-icon-cache ]] && gtk-update-icon-cache -q -f -t /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/lcmc.png b/lcmc.png
new file mode 100644
index 000000000000..9c374edaa4c4
--- /dev/null
+++ b/lcmc.png
Binary files differ