summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-10-27 00:22:21 +0800
committerChocobo12017-10-27 00:27:31 +0800
commitea41e24de735e075b7c9ceee959c098d7d3a78e8 (patch)
tree69adcf5fd7f9875ebef9b6f3fcdfdc96280edd17
downloadaur-ea41e24de735e075b7c9ceee959c098d7d3a78e8.tar.gz
newpkg: lcms2-git 2.9rc1.r12.g66aeefe-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c64102d3a08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lcms2-git
+ pkgdesc = Small-footprint color management engine
+ pkgver = 2.9rc1.r12.g66aeefe
+ pkgrel = 1
+ url = http://www.littlecms.com/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glibc
+ depends = libtiff
+ provides = lcms2
+ conflicts = lcms2
+ options = staticlibs
+ source = git+https://github.com/mm2/Little-CMS.git
+ sha256sums = SKIP
+
+pkgname = lcms2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3028ff6ff529
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=lcms2-git
+pkgver=2.9rc1.r12.g66aeefe
+pkgrel=1
+pkgdesc="Small-footprint color management engine"
+arch=('i686' 'x86_64')
+url="http://www.littlecms.com/"
+license=('MIT')
+depends=('glibc' 'libtiff')
+makedepends=('git')
+provides=('lcms2')
+conflicts=('lcms2')
+options=('staticlibs')
+source=("git+https://github.com/mm2/Little-CMS.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "Little-CMS"
+
+ git describe --long --tags | sed 's/^lcms//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "Little-CMS"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "Little-CMS"
+
+ make check
+}
+
+package() {
+ cd "Little-CMS"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/lcms2/COPYING"
+}