summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Claßen2023-02-17 23:33:24 +0100
committerPhilipp Claßen2023-02-17 23:33:24 +0100
commit2473fa5de534ff178e746b4e724b82b70546c1f7 (patch)
treee799d3467ddfb544137397639f2ceb00aff764c5
parenta9127e8c20f12f84e7bef66f27e219e07080f684 (diff)
downloadaur-2473fa5de534ff178e746b4e724b82b70546c1f7.tar.gz
- Include fixes from alkino (dependencies and listing /usr/lib)
- Fixed: use "https" instead of the now deprecated "git" protocol
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30de5610871d..f5c971866eac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = lcov-git
pkgdesc = Latest snapshot of lcov, a front-end for GCC's coverage testing tool gcov
- pkgver = r346.b9d6727
+ pkgver = r406.43534e8
pkgrel = 1
url = http://ltp.sourceforge.net/coverage/lcov.php
arch = any
license = GPL
makedepends = git
depends = perl
+ depends = perl-capture-tiny
+ depends = perl-datetime
+ depends = perl-json-xs
provides = lcov
conflicts = lcov
- source = git://github.com/linux-test-project/lcov.git
+ source = git+https://github.com/linux-test-project/lcov.git
md5sums = SKIP
pkgname = lcov-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7a67031d23cd..ed02b8f8b387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# you should probably just stick with the aur/lcov package.
#
pkgname=lcov-git
-pkgver=r346.b9d6727
+pkgver=r406.43534e8
pkgrel=1
pkgdesc="Latest snapshot of lcov, a front-end for GCC's coverage testing tool gcov"
arch=('any')
@@ -15,11 +15,14 @@ url="http://ltp.sourceforge.net/coverage/lcov.php"
license=('GPL')
depends=(
'perl'
+ 'perl-capture-tiny'
+ 'perl-datetime'
+ 'perl-json-xs'
)
makedepends=('git')
conflicts=('lcov')
provides=('lcov')
-source=('git://github.com/linux-test-project/lcov.git')
+source=('git+https://github.com/linux-test-project/lcov.git')
md5sums=('SKIP')
pkgver() {
@@ -35,4 +38,5 @@ package() {
mkdir -p "$pkgdir/usr"
test -d "$pkgdir/usr/bin" || mv "$pkgdir/bin" "$pkgdir/usr/bin"
test -d "$pkgdir/usr/share" || mv "$pkgdir/share" "$pkgdir/usr/share"
+ test -d "$pkgdir/usr/lib" || mv "$pkgdir/lib" "$pkgdir/usr/lib"
}