summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValeriy Huz2018-05-28 00:55:49 +0300
committerValeriy Huz2018-05-28 00:55:49 +0300
commit15cb7634a56ac86c9f4b46cc2a8b66075bd42d28 (patch)
treeb3d50df3d45feecae7a0510cd313cf439cf8f6a5
parent6de614aa0276b3244c5b7908e8c59a3c59fd03d0 (diff)
downloadaur-15cb7634a56ac86c9f4b46cc2a8b66075bd42d28.tar.gz
removed wrapper, changed openblas dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 5 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07581d101942..2cc8788e7f7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lczero-nvidia-git
pkgdesc = This is an adaptation of GCP's Leela Zero repository to chess, using Stockfish's position representation and move generation.
pkgver = 0.10
- pkgrel = 299
+ pkgrel = 1
url = https://github.com/glinscott/leela-chess
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = lczero-nvidia-git
makedepends = ocl-icd
depends = glibc
depends = zlib
- depends = libopenblas
+ depends = openblas
depends = boost
depends = opencl-nvidia
source = leela-chess::git+https://github.com/glinscott/leela-chess
diff --git a/PKGBUILD b/PKGBUILD
index e64339913401..fff10700aa05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,16 @@
pkgname=lczero-nvidia-git
_pkgname=leela-chess
pkgver=0.10
-pkgrel=299
+pkgrel=1
pkgdesc="This is an adaptation of GCP's Leela Zero repository to chess, using Stockfish's position representation and move generation."
arch=('i686' 'x86_64')
url="https://github.com/glinscott/leela-chess"
license=('GPLv3')
-depends=('glibc' 'zlib' 'libopenblas' 'boost' 'opencl-nvidia')
+depends=('glibc' 'zlib' 'openblas' 'boost' 'opencl-nvidia')
makedepends=('git' 'opencl-headers' 'cmake' 'ocl-icd')
source=("${_pkgname}::git+https://github.com/glinscott/leela-chess")
md5sums=('SKIP')
-prepare() {
- cd ${srcdir}/${_pkgname}
- wget http://lczero.org/get_network?sha=705132aeb89a8a3a71226bd56f1af8a08b97344c353bab4ed5e015a70b8512ec -O weights_$pkgrel.txt
- echo '#!/bin/bash' > lczero
- echo "/usr/bin/lczero-bin -w /usr/share/lczero/weights_$pkgrel.txt" >> lczero
-}
-
build() {
cd ${srcdir}/${_pkgname}
git submodule update --init --recursive
@@ -35,7 +28,5 @@ check() {
package() {
cd "$srcdir/$_pkgname"
- install -Dm755 build/lczero $pkgdir/usr/bin/lczero-bin
- install -Dm755 lczero $pkgdir/usr/bin/lczero
- install -Dm644 weights_$pkgrel.txt $pkgdir/usr/share/lczero/weights_$pkgrel.txt
+ install -Dm755 build/lczero $pkgdir/usr/bin/lczero
}