summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWithHat2015-07-04 05:58:48 +0200
committerWithHat2015-07-04 05:58:48 +0200
commit00128e24dd89210ae39d6cdf98b3a3201d9a0526 (patch)
tree4c9e8559c27a9d64d4081c6e001c1e4aec5b37af
downloadaur-00128e24dd89210ae39d6cdf98b3a3201d9a0526.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD64
-rw-r--r--apache.example.conf9
-rw-r--r--dont-look-for-alternate-perl.patch17
-rw-r--r--fix-htmldir-and-docdir.patch25
5 files changed, 141 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ee00bde7719
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = ldap-account-manager
+ pkgdesc = A webfrontend for managing entries stored in an LDAP directory
+ pkgver = 4.4
+ pkgrel = 1
+ url = https://www.ldap-account-manager.org/
+ arch = any
+ license = GPL
+ depends = php>=5.2.4
+ depends = php-ldap
+ depends = openldap>2.0
+ optdepends = php-mcrypt: Store LDAP password encrypted in the session file
+ optdepends = perl
+ optdepends = php-apache: Run LDAP Account Manager on Apache
+ optdepends = php-fpm: Run LDAP Account Manager on other webservers
+ options = !strip
+ source = http://downloads.sourceforge.net/lam/ldap-account-manager-4.4.tar.bz2
+ source = dont-look-for-alternate-perl.patch
+ source = fix-htmldir-and-docdir.patch
+ source = apache.example.conf
+ md5sums = 7ed89d9fd935ae44fa7236b06a255550
+ md5sums = a9674e38ec4a6e2e8c4c939212c60250
+ md5sums = d32a8d1d4863fe89fda04722404a621f
+ md5sums = 288c8e57cc9f701050d35b79d70d66e8
+
+pkgname = ldap-account-manager
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca8d0a1756b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Dominik Peteler <archlinux@with-h.at>
+
+pkgname=ldap-account-manager
+pkgver=4.4
+pkgrel=1
+pkgdesc="A webfrontend for managing entries stored in an LDAP directory"
+arch=('any')
+url="https://www.ldap-account-manager.org/"
+license=('GPL')
+depends=('php>=5.2.4' 'php-ldap' 'openldap>2.0')
+optdepends=('php-mcrypt: Store LDAP password encrypted in the session file'
+ 'perl'
+ 'php-apache: Run LDAP Account Manager on Apache'
+ 'php-fpm: Run LDAP Account Manager on other webservers')
+options=('!strip')
+source=(http://downloads.sourceforge.net/lam/${pkgname}-${pkgver}.tar.bz2
+ dont-look-for-alternate-perl.patch
+ fix-htmldir-and-docdir.patch
+ apache.example.conf)
+md5sums=('7ed89d9fd935ae44fa7236b06a255550'
+ 'a9674e38ec4a6e2e8c4c939212c60250'
+ 'd32a8d1d4863fe89fda04722404a621f'
+ '288c8e57cc9f701050d35b79d70d66e8')
+
+_webroot="usr/share/webapps/${pkgname}"
+_confdir="etc/webapps/${pkgname}"
+_docdir="usr/share/doc/${pkgname}"
+_datadir="var/lib/${pkgname}"
+
+prepare() {
+ cd "$srcdir"
+ patch "$pkgname-$pkgver/configure.ac" dont-look-for-alternate-perl.patch
+ patch "$pkgname-$pkgver/Makefile.in" fix-htmldir-and-docdir.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --with-httpd-user=http \
+ --with-httpd-group=http \
+ --with-web-root=/${_webroot} \
+ --sysconfdir=/${_confdir} \
+ --localstatedir=/${_datadir} \
+ --docdir=/${_docdir}
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 $srcdir/apache.example.conf $pkgdir/${_docdir}/apache.example.conf
+
+ cd "$pkgdir"
+
+ chown http:http ${_datadir}
+ chmod 775 ${_confdir}
+
+ sed -i \
+ -e 's#/bin/#/usr/bin/#' \
+ ${_confdir}/templates/profiles/default.user
+ sed -i \
+ -e 's#/bin/#/usr/bin/#' \
+ ${_webroot}/lib/modules/posixAccount.inc
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..26a14f1d9c3d
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,9 @@
+Alias /lam /usr/share/webapps/ldap-account-manager
+
+<IfModule php5_module>
+<Directory /usr/share/webapps/ldap-account-manager>
+ Options FollowSymLinks
+ php_value memory_limit 64M
+ php_value open_basedir "/usr/share/webapps/ldap-account-manager:/var/lib/ldap-account-manager:/etc/webapps/ldap-account-manager:/tmp"
+</Directory>
+</IfModule>
diff --git a/dont-look-for-alternate-perl.patch b/dont-look-for-alternate-perl.patch
new file mode 100644
index 000000000000..419d1bc96a72
--- /dev/null
+++ b/dont-look-for-alternate-perl.patch
@@ -0,0 +1,17 @@
+--- src/ldap-account-manager-4.2.1/configure.ac 2013-06-17 21:09:37.000000000 +0200
++++ configure.ac.modified 2013-07-31 18:07:19.182647332 +0200
+@@ -116,13 +116,7 @@
+ fi
+ ],
+ [
+-# We search these paths before $PATH to find a more up-to-date/capable
+-# version of perl than the system installed one.
+- TestPath="/opt/bin"
+- TestPath="${TestPath}${PATH_SEPARATOR}/opt/sfw/bin"
+- TestPath="${TestPath}${PATH_SEPARATOR}/usr/local/bin"
+- TestPath="${TestPath}${PATH_SEPARATOR}$PATH"
+- AC_PATH_PROGS(perl_path, perl5 perl, , $TestPath)
++ AC_PATH_PROGS(perl_path, perl5 perl)
+ ]
+ )
+
diff --git a/fix-htmldir-and-docdir.patch b/fix-htmldir-and-docdir.patch
new file mode 100644
index 000000000000..bb3fef039eec
--- /dev/null
+++ b/fix-htmldir-and-docdir.patch
@@ -0,0 +1,25 @@
+--- src/ldap-account-manager-4.2.1/Makefile.in 2013-06-17 21:09:37.000000000 +0200
++++ Makefile.in.modified 2013-07-31 18:45:48.246058432 +0200
+@@ -24,7 +24,8 @@
+ sysconfdir=@sysconfdir@
+ localstatedir=@localstatedir@
+ mandir=@mandir@
+-htmldir=@prefix@/html
++docdir=@docdir@
++htmldir=@htmldir@
+ web_root=@WEB_ROOT@
+
+ srcdir=@srcdir@
+@@ -73,9 +74,9 @@
+ (cd $(DESTDIR)$(sysconfdir) ; $(TAR) xf -) ; \
+ $(LN_S) $(sysconfdir) ${LIST3} ; \
+ (cd $(srcdir) ; $(TAR) cf - $(LIST1)) | $(TAR) xf - ; \
+- [ -d $(DESTDIR)$(prefix)/docs ] || \
+- $(MKDIR) -p $(DESTDIR)$(prefix)/docs || exit 1 ; \
+- (cd $(srcdir) ; $(COPY) $(DOCS) $(DESTDIR)$(prefix)/docs) ; \
++ [ -d $(DESTDIR)$(docdir) ] || \
++ $(MKDIR) -p $(DESTDIR)$(docdir) || exit 1 ; \
++ (cd $(srcdir) ; $(COPY) $(DOCS) $(DESTDIR)$(docdir)) ; \
+ $(PERL) -pi -e "s~/usr/bin/perl~$(PERL)~" \
+ $(DESTDIR)$(web_root)/lib/lamdaemon.pl ; \
+ cd $${HERE} ; \