summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2016-12-07 19:46:57 -0500
committerBen Wolsieffer2016-12-07 19:46:57 -0500
commit3a4677a5202b245967c87ae7abc707208c506d45 (patch)
tree485b0559c2114a079ad4b40dd448ec3547a6ce8c
downloadaur-3a4677a5202b245967c87ae7abc707208c506d45.tar.gz
Version 1.5
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD53
-rw-r--r--license.txt11
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e56e2c71899
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Dec 8 00:46:45 UTC 2016
+pkgbase = ldcad
+ pkgdesc = A multiplatform LDraw (virtual LEGO) editor that lets you edit LDraw model documents in real-time
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://www.melkert.net/LDCad
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ depends = glu
+ depends = xdg-utils
+ backup = etc/LDCad.cfg
+ source = license.txt
+ md5sums = 9917fda1740c892e0e7d240fb4fd8812
+ source_i686 = http://www.melkert.net/action/download/LDCad-1-5-Linux-32.tar.bz2
+ md5sums_i686 = 9855dab2af49cb68405fd254c44f2b96
+ source_x86_64 = http://www.melkert.net/action/download/LDCad-1-5-Linux-64.tar.bz2
+ md5sums_x86_64 = 9448e18efe67da91fba0e424c18aa726
+
+pkgname = ldcad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4897480ebda8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
+pkgname=ldcad
+pkgver=1.5
+pkgrel=1
+pkgdesc="A multiplatform LDraw (virtual LEGO) editor that lets you edit LDraw model documents in real-time"
+arch=('i686' 'x86_64')
+url="http://www.melkert.net/LDCad"
+license=('custom')
+depends=('gtk2' 'glu' 'xdg-utils')
+backup=('etc/LDCad.cfg')
+source_i686=("http://www.melkert.net/action/download/LDCad-${pkgver//./-}-Linux-32.tar.bz2")
+source_x86_64=("http://www.melkert.net/action/download/LDCad-${pkgver//./-}-Linux-64.tar.bz2")
+source=('license.txt')
+md5sums=('9917fda1740c892e0e7d240fb4fd8812')
+md5sums_i686=('9855dab2af49cb68405fd254c44f2b96')
+md5sums_x86_64=('9448e18efe67da91fba0e424c18aa726')
+
+if [ "$CARCH" == x86_64 ]; then
+ _srcname=LDCad-${pkgver//./-}-Linux-64/
+elif [ "$CARCH" == i686 ]; then
+ _srcname=LDCad-${pkgver//./-}-Linux-32/
+fi
+
+prepare() {
+ cd "${srcdir}/${_srcname}"
+ # Make the setup script install to the correct paths
+ sed -i -e "s:/usr:$pkgdir/usr:" \
+ -e "s:/etc:$pkgdir/etc:" \
+ -e '/update-mime-database/d' \
+ -e '/update-desktop-database/d' setup.sh
+}
+
+package() {
+ # Create directories the installer is expecting to find
+ cd "${pkgdir}"
+ mkdir -p usr/bin
+ mkdir -p etc
+ mkdir -p usr/share/mime/packages/
+ mkdir -p usr/share/applications/
+
+ # Run installer
+ cd "${srcdir}/${_srcname}"
+ ./setup.sh
+
+ # Remove references to $pkgdir in config and desktop file
+ sed -i -e "s:$pkgdir::" \
+ "${pkgdir}/etc/LDCad.cfg" \
+ "${pkgdir}/usr/share/applications/LDCad.desktop"
+
+ # Install license
+ install -D -m644 "${srcdir}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..f3cadd87b6e7
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,11 @@
+LDCad license agreement (v2).
+
+LDCad, the software from here on, is freeware and may be used non-commercially without charge by anyone.
+
+Using the software to (partly) create material to be sold later on is only permitted when done at a small (non corporate) scale. In such cases a single unit of the aforementioned material must be donated to the author as a form of payment.
+
+The author (Roland Melkert) does not guarantee perfect operation of the software, nor can he be held responsible for any damage or loss resulting from the use of the software in anyway.
+
+By using the software you agree with the contents of this document and therefore agree with the license.
+
+For questions and contact- or additional information visit melkert.net/LDCad.