summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLemonBoy2015-08-01 12:02:25 +0200
committerLemonBoy2015-08-01 12:02:25 +0200
commiteb9e874211ed3e17bf33ff90f2fd805a165960fe (patch)
tree7fc178235011bc2848409ad5482f375d5da620a9
downloadaur-eb9e874211ed3e17bf33ff90f2fd805a165960fe.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
-rw-r--r--ldm.install12
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb5009c9548d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ldm
+ pkgdesc = A lightweight device mounter
+ pkgver = 0.6.2
+ pkgrel = 2
+ url = https://github.com/LemonBoy/ldm
+ install = ldm.install
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = MIT
+ depends = udev
+ depends = glib2
+ provides = ldm
+ conflicts = ldm-git
+ source = ldm-0.6.2.tar.gz::http://github.com/lemonboy/ldm/archive/v0.6.2.tar.gz
+ sha256sums = 14484ac229f8d6558f007ec1c139e5ada2d3c60230a55f99f939022cfd493c9b
+
+pkgname = ldm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c59786d05219
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+## ldm PKGBUILD
+# Maintainer: The Lemon Man
+
+pkgname=ldm
+pkgver=0.6.2
+pkgrel=2
+pkgdesc="A lightweight device mounter"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://github.com/LemonBoy/ldm"
+license=('MIT')
+depends=('udev' 'glib2')
+provides=('ldm')
+conflicts=('ldm-git')
+install=$pkgname.install
+source=("$pkgname-$pkgver.tar.gz"::"http://github.com/lemonboy/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('14484ac229f8d6558f007ec1c139e5ada2d3c60230a55f99f939022cfd493c9b')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/ldm.install b/ldm.install
new file mode 100644
index 000000000000..e392e90c82c7
--- /dev/null
+++ b/ldm.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo 'ldm expects a config file at /etc/ldm.conf containing your user and group id (uid and gid respectively).'
+ echo 'Just add those three lines into it:'
+ echo 'USER_GID=<output of `id -g` ran from your user>'
+ echo 'USER_UID=<output of `id -u` ran from your user>'
+ echo 'BASE_MOUNTPOINT=/mnt/'
+}
+post_upgrade() {
+ if [ ! -f /etc/ldm.conf ]; then
+ echo 'NOTE: The configuration file has been moved to /etc/ldm.conf'
+ fi
+}