summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2022-04-17 23:49:53 -0400
committerChris Severance2022-04-17 23:49:53 -0400
commit0e6e3035cd873bdba0d2926e3724fb9b27fe2d7f (patch)
treeb86dc8b5553709d0fba79509d0699b78a8b86a33
parentc2cdd2b5bc5b05b98a1652eb039c8c106b1b34a7 (diff)
downloadaur-0e6e3035cd873bdba0d2926e3724fb9b27fe2d7f.tar.gz
Update to 1.16.8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bba03781a6f6..5bbc93515656 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Jun 18 23:57:22 UTC 2020
pkgbase = le
pkgdesc = A text editor in memorial to Norton Editor with block and binary operations
- pkgver = 1.16.7
+ pkgver = 1.16.8
pkgrel = 1
url = https://github.com/lavv17/le
arch = i686
@@ -10,11 +8,12 @@ pkgbase = le
license = GPL3
makedepends = git
source = git://git.sv.gnu.org/gnulib
- source = le-1.16.7.tar.gz::https://github.com/lavv17/le/archive/v1.16.7.tar.gz
+ source = le-1.16.8.tar.gz::https://github.com/lavv17/le/archive/refs/tags/v1.16.8.tar.gz
+ md5sums = SKIP
+ md5sums = 94a24b344084324f07ab1a4fd3181fda
sha256sums = SKIP
- sha256sums = 93ee87b1d2eb6dcc2bf9b43653baba78d3f89f18b339761a6e0a5521cd865e6d
+ sha256sums = 6c5a0e3bfbc522e57953f237269c1772283454fb6947f6257fde99d48ea9c3b1
pkgname = le
depends = gcc-libs
depends = ncurses
-
diff --git a/PKGBUILD b/PKGBUILD
index 7ad4f6f72b4c..edf32aa3bfa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,24 +6,26 @@
set -u
_pkgname='le'
pkgname="${_pkgname}"
-pkgver=1.16.7
-pkgrel=1
+pkgver='1.16.8'
+pkgrel='1'
pkgdesc='A text editor in memorial to Norton Editor with block and binary operations'
arch=('i686' 'x86_64')
#url='https://directory.fsf.org/wiki/Le_editor'
url="https://github.com/lavv17/${_pkgname}"
license=('GPL3')
makedepends=('git')
-_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
+#_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
_srcdir="${_pkgname}-${pkgver}"
#source=("http://fossies.org/linux/misc/${_pkgname}-${pkgver}.tar.xz")
#source=("http://lav.yar.ru/download/le/${_pkgname}-${pkgver}.tar.gz")
source=(
'git://git.sv.gnu.org/gnulib'
- "${_pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
+ "${_pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz"
)
+md5sums=('SKIP'
+ '94a24b344084324f07ab1a4fd3181fda')
sha256sums=('SKIP'
- '93ee87b1d2eb6dcc2bf9b43653baba78d3f89f18b339761a6e0a5521cd865e6d')
+ '6c5a0e3bfbc522e57953f237269c1772283454fb6947f6257fde99d48ea9c3b1')
if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
unset _verwatch
@@ -55,8 +57,7 @@ build() {
./configure --prefix='/usr' CXX='g++'
fi
fi
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
- nice make -s -j "${_nproc}"
+ nice make -s
set +u
}